Closed Bug 1557947 Opened 4 months ago Closed 4 months ago

Intermittent runner.py | application crashed [@ mozilla::dom::ClientSource::SnapshotState(mozilla::dom::ClientState*)]

Categories

(Testing :: Raptor, defect, critical)

Version 3
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1544683

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: crash, intermittent-failure, regression)

Crash Data

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=250757275&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/fsP5qOTQQKOcJOzUNWYAng/runs/0/artifacts/public/logs/live_backing.log


10:37:52 INFO - raptor-main Info: starting firefox
10:37:52 INFO - Application command: /home/cltbld/tasks/task_1559989987/build/application/firefox/firefox -profile /tmp/tmp_HDmLp.mozrunner
10:37:53 INFO - raptor-control-server Info: received webext_status: raptor runner.js is loaded!
10:37:53 INFO - raptor-control-server Info: reading test settings from raptor-tp6-outlook-firefox.json
10:37:53 INFO - raptor-control-server Info: sent test settings to web ext runner
10:37:53 INFO - raptor-control-server Info: received webext_status: * pausing 30 seconds to let browser settle... *
10:38:23 INFO - raptor-control-server Info: received webext_status: running 25 pagecycles of https://outlook.live.com/mail/inbox
10:38:23 INFO - raptor-control-server Info: received webext_status: opened new empty tab: 3
10:38:24 INFO - raptor-control-server Info: received webext_status: begin pagecycle 1
10:38:25 INFO - raptor-control-server Info: received webext_status: update tab: 3
10:38:25 INFO - raptor-control-server Info: received webext_status: test tab updated: 3
10:38:27 INFO - raptor-control-server Info: received webext_status: results received
10:38:28 INFO - raptor-control-server Info: received webext_status: begin pagecycle 2
10:38:29 INFO - raptor-control-server Info: received webext_status: update tab: 3
10:38:29 INFO - raptor-control-server Info: received webext_status: test tab updated: 3
10:38:30 INFO - raptor-control-server Info: received webext_status: results received
10:38:31 INFO - raptor-control-server Info: received webext_status: begin pagecycle 3
10:38:32 INFO - raptor-control-server Info: received webext_status: update tab: 3
10:38:32 INFO - raptor-control-server Info: received webext_status: test tab updated: 3
10:38:33 INFO - raptor-control-server Info: received webext_status: results received
10:38:34 INFO - raptor-control-server Info: received webext_status: begin pagecycle 4
10:38:35 INFO - raptor-control-server Info: received webext_status: update tab: 3
10:38:35 INFO - raptor-control-server Info: received webext_status: test tab updated: 3
10:39:05 INFO - raptor-control-server Info: received webext_raptor-page-timeout: [u'raptor-tp6-outlook-firefox', u'https://outlook.live.com/mail/inbox', {u'fcp': True, u'hero': False, u'dcf': True, u'fnb paint': True, u'ttfi': False, u'load time': True}]
10:39:05 INFO - raptor-control-server Info: received webext_screenshot
10:39:05 INFO - raptor-results-handler Info: received screenshot
10:39:05 INFO - raptor-control-server Info: received webext_status: Removed tab: 3
10:39:05 INFO - raptor-control-server Info: received request to shutdown the browser
10:39:05 INFO - raptor-control-server Info: shutting down browser (pid: 5387)
10:39:21 INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/ApQHgstvS6yqrotOMkyv9A/artifacts/public/build/target.crashreporter-symbols.zip
10:39:25 INFO - mozcrash Copy/paste: /home/cltbld/tasks/task_1559989987/build/linux64-minidump_stackwalk /tmp/tmp_HDmLp.mozrunner/minidumps/7637d047-15c8-b485-7292-303684e6cb50.dmp /tmp/tmpxi5n4p
10:39:28 INFO - mozcrash Saved minidump as /home/cltbld/tasks/task_1559989987/build/blobber_upload_dir/7637d047-15c8-b485-7292-303684e6cb50.dmp
10:39:28 INFO - mozcrash Saved app info as /home/cltbld/tasks/task_1559989987/build/blobber_upload_dir/7637d047-15c8-b485-7292-303684e6cb50.extra
10:39:28 ERROR - PROCESS-CRASH | runner.py | application crashed [@ mozilla::dom::ClientSource::SnapshotState(mozilla::dom::ClientState*)]
10:39:28 INFO - Crash dump filename: /tmp/tmp_HDmLp.mozrunner/minidumps/7637d047-15c8-b485-7292-303684e6cb50.dmp
10:39:28 INFO - Operating system: Linux
10:39:28 INFO - 0.0.0 Linux 4.4.0-66-generic #87-Ubuntu SMP Fri Mar 3 15:29:05 UTC 2017 x86_64
10:39:28 INFO - CPU: amd64
10:39:28 INFO - family 6 model 94 stepping 3
10:39:28 INFO - 1 CPU
10:39:28 INFO - GPU: UNKNOWN
10:39:28 INFO - Crash reason: SIGSEGV /SEGV_MAPERR
10:39:28 INFO - Crash address: 0x0
10:39:28 INFO - Process uptime: not available
10:39:28 INFO - Thread 0 (crashed)
10:39:28 INFO - 0 libxul.so!mozilla::dom::ClientSource::SnapshotState(mozilla::dom::ClientState*) [ClientSource.cpp:b5355bd2162ba5740469820ee518649e7fc0b953 : 639 + 0x11]
10:39:28 INFO - rax = 0x00007f68297e23a6 rdx = 0x00007f681ba4f1a8
10:39:28 INFO - rcx = 0x0000561336939b28 rbx = 0x00007f6813e08180
10:39:28 INFO - rsi = 0x00007f681ba4f1a8 rdi = 0x00007f6816849560
10:39:28 INFO - rbp = 0x00007ffc9c9fdf70 rsp = 0x00007ffc9c9fdf30
10:39:28 INFO - r8 = 0x0000000000000000 r9 = 0x0000000000000000

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1544683
You need to log in before you can comment on or make changes to this bug.