Closed Bug 1557997 Opened 5 months ago Closed 5 months ago

IDB: Add more IsShuttingDown checks to database maintenance

Categories

(Core :: DOM: IndexedDB, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: janv, Assigned: janv)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

According to:
https://crash-stats.mozilla.org/report/index/6803ac22-3260-4342-bfad-624330190607#tab-metadata
the IDB shutdown timer fired when an IDB maintenance thread was actively running the integrity check. This can take long time on a big database. DatabaseMaintenance::AutoProgressHandler::OnProgress now interrupts the operation only when the maintenance was aborted (triggered by StopIdleMaintenance). I think we should also add the IsShuttingDown check there.
There are other places in the maintenance code, especially looping over directory entries that need these checks.

Pushed by jvarga@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bc502c949746
IDB: Add more IsShuttingDown checks to database maintenance; r=asuth
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9070818 [details]
Bug 1557997 - IDB: Add more IsShuttingDown checks to database maintenance; r=asuth

Beta/Release Uplift Approval Request

  • User impact if declined: Users may experience shutdown hangs caused by long running database maintenance operations.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change is simple. We just interrupt a database maintenance operation when we are shutting down.
  • String changes made/needed: None
Attachment #9070818 - Flags: approval-mozilla-beta?

Comment on attachment 9070818 [details]
Bug 1557997 - IDB: Add more IsShuttingDown checks to database maintenance; r=asuth

shutdown hang prevention, approved for 68.0b10

Attachment #9070818 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.