Closed Bug 1558122 Opened 3 years ago Closed 2 years ago

Intermittent devtools/client/webreplay/mochitest/browser_rr_inspector-02.js | A promise chain failed to handle a rejection: Protocol error (unknownError): Recording divergence in objectApply - stack: (No stack available.)

Categories

(Core Graveyard :: Web Replay, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1546369

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, regression)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=250873653&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/a3H0h-eJQ_K3c_a8WuiYVQ/runs/0/artifacts/public/logs/live_backing.log


06:19:32 INFO - TEST-START | devtools/client/webreplay/mochitest/browser_rr_inspector-02.js
06:19:32 INFO - GECKO(1670) | MIDDLEMAN 1808 /var/folders/jx/l1dzhc412d92ng9hjbmn7d4w000017/T/TempRecording.1670.19
06:19:32 INFO - GECKO(1670) | RECORDING 1809 /var/folders/jx/l1dzhc412d92ng9hjbmn7d4w000017/T/TempRecording.1670.19
06:19:34 INFO - GECKO(1670) | REPLAYING 1810 /var/folders/jx/l1dzhc412d92ng9hjbmn7d4w000017/T/TempRecording.1670.19

06:20:18 INFO - TEST-PASS | devtools/client/webreplay/mochitest/browser_rr_inspector-02.js | Source is doc_inspector_basic.html -
06:20:18 INFO - Buffered messages logged at 06:19:37
06:20:18 INFO - Opening the inspector
06:20:18 INFO - Opening the toolbox
06:20:18 INFO - TEST-PASS | devtools/client/webreplay/mochitest/browser_rr_inspector-02.js | Paused at line 9 expected 9 -
06:20:18 INFO - Buffered messages logged at 06:19:38
06:20:18 INFO - Console message: [JavaScript Warning: "This site appears to use a scroll-linked positioning effect. This may not work well with asynchronous panning; see https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects for further details and to join the discussion on related tools and features!" {file: "chrome://devtools/content/debugger/index.html" line: 0}]
06:20:18 INFO - Buffered messages logged at 06:19:39
06:20:18 INFO - Toolbox opened and focused
06:20:18 INFO - Waiting for element picker to become active.
06:20:18 INFO - Moving mouse over div.
06:20:18 INFO - Waiting for element #maindiv to be highlighted
06:20:18 INFO - Console message: [JavaScript Error: "uncaught exception: Protocol error (unknownError): Recording divergence in objectApply"]
06:20:18 INFO - Buffered messages finished
06:20:18 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webreplay/mochitest/browser_rr_inspector-02.js | Test timed out -
06:20:18 INFO - GECKO(1670) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn17.child1/context18' can't be sent as the connection is closed."
06:20:19 INFO - Removing tab.
06:20:19 INFO - Waiting for event: 'TabClose' on [object XULElement].
06:20:19 INFO - Got event: 'TabClose' on [object XULElement].
06:20:19 INFO - Tab removed and finished closing
06:20:19 INFO - Not taking screenshot here: see the one that was previously logged
06:20:19 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webreplay/mochitest/browser_rr_inspector-02.js | A promise chain failed to handle a rejection: Protocol error (unknownError): Recording divergence in objectApply - stack: (No stack available.)
06:20:19 INFO - Rejection date: Mon Jun 10 2019 06:19:39 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
06:20:19 INFO - Stack trace:
06:20:19 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
06:20:19 INFO - chrome://mochikit/content/browser-test.js:nextTest:754
06:20:19 INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1211
06:20:19 INFO - setTimeout handler*chrome://mochikit/content/browser-test.js:Tester_execTest:1173
06:20:19 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1004
06:20:19 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
06:20:19 INFO - GECKO(1670) | MEMORY STAT | vsize 7871MB | residentFast 564MB | heapAllocated 197MB
06:20:19 INFO - TEST-OK | devtools/client/webreplay/mochitest/browser_rr_inspector-02.js | took 46251ms

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1546369
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.