Closed Bug 1558186 Opened 3 years ago Closed 3 years ago

Prevent crashing in debug_message_insert_khr on pixel 2

Categories

(Core :: Graphics: WebRender, defect, P3)

Other Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1559834

People

(Reporter: kats, Unassigned)

References

Details

I did a try push with the gecko reftest suite running on Pixel 2 devices in bitbar, and a number of the jobs crashed in debug_message_insert_khr. Here's the top of the stack from this job

20:57:33     INFO -  CPU: arm
20:57:33     INFO -       ARMv1 Qualcomm part(0x51008010) features: half,thumb,fastmult,vfpv2,edsp,neon,vfpv3,tls,vfpv4,idiva,idivt
20:57:33     INFO -       8 CPUs
20:57:33     INFO -  GPU: UNKNOWN
20:57:33     INFO -  Crash reason:  SIGSEGV /SEGV_ACCERR
20:57:33     INFO -  Crash address: 0xc23ff000
20:57:33     INFO -  Process uptime: not available
20:57:33     INFO -  Thread 39 (crashed)
20:57:33     INFO -   0  libc.so + 0x3d2a8
20:57:33     INFO -       r0 = 0x000000e5    r1 = 0xc23fe400    r2 = 0x00000000    r3 = 0xc23ff000
20:57:33     INFO -       r4 = 0xcaf08080    r5 = 0xc23fe400    r6 = 0x00000007    r7 = 0x00000006
20:57:33     INFO -       r8 = 0x0000824a    r9 = 0x00000009   r10 = 0x0000006c   r12 = 0x00000030
20:57:33     INFO -       fp = 0xcaf07d60    sp = 0xc6ffece8    lr = 0xd6b83863    pc = 0xf34402a8
20:57:33     INFO -      Found by: given as instruction pointer in context
20:57:33     INFO -   1  libGLESv2_adreno.so + 0x93773
20:57:33     INFO -       sp = 0xc6ffed48    pc = 0xd6b63775
20:57:33     INFO -      Found by: stack scanning
20:57:33     INFO -   2  libxul.so!<gleam::gl::GlesFns as gleam::gl::Gl>::debug_message_insert_khr [gles_fns.rs:d22f07a8f0f9e2f349e0b366f5207c39f0208496 : 1962 + 0x3]
20:57:33     INFO -       sp = 0xc6ffed54    pc = 0xd31d0407
20:57:33     INFO -      Found by: stack scanning
20:57:33     INFO -   3  0xc6ffef3a
20:57:33     INFO -       r4 = 0xd315c5b1    r5 = 0x00000006    r7 = 0x0000000a    sp = 0xc6ffed6c
20:57:33     INFO -       pc = 0xc6ffef3c
20:57:33     INFO -      Found by: call frame info
20:57:33     INFO -   4  libxul.so!webrender::device::query_gl::GpuMarker::new [query_gl.rs:d22f07a8f0f9e2f349e0b366f5207c39f0208496 : 289 + 0x1d]
20:57:33     INFO -       sp = 0xc6ffed80    pc = 0xd3092dcd
20:57:33     INFO -      Found by: stack scanning
20:57:33     INFO -   5  libxul.so!webrender::renderer::Renderer::draw_tile_frame [query_gl.rs:d22f07a8f0f9e2f349e0b366f5207c39f0208496 : 272 + 0xb]
20:57:33     INFO -       r4 = 0xc23fe400    r5 = 0xc6ffefec    r6 = 0xc54b9a28    sp = 0xc6ffeda0
20:57:33     INFO -       pc = 0xd305e1d3
20:57:33     INFO -      Found by: call frame info
20:57:33     INFO -   6  libGLESv2_adreno.so + 0xf42d7
20:57:33     INFO -       sp = 0xc6ffedb8    pc = 0xd6bc42d9
20:57:33     INFO -      Found by: stack scanning
20:57:33     INFO -   7  libGLESv2_adreno.so + 0x8fba5
20:57:33     INFO -       sp = 0xc6ffee20    pc = 0xd6b5fba7
20:57:33     INFO -      Found by: stack scanning
20:57:33     INFO -   8  libxul.so!<gleam::gl::GlesFns as gleam::gl::Gl>::tex_sub_image_3d_pbo [gles_fns.rs:d22f07a8f0f9e2f349e0b366f5207c39f0208496 : 802 + 0x21]
20:57:33     INFO -       sp = 0xc6ffee68    pc = 0xd31cf4bd
20:57:33     INFO -      Found by: stack scanning
20:57:33     INFO -   9  0xc6ffeff2
20:57:33     INFO -       r4 = 0xd4d292a8    r5 = 0xc6ffeff4    r6 = 0xc54b6008    r7 = 0xc54b972c
20:57:33     INFO -       sp = 0xc6ffee98    pc = 0xc6ffeff4
20:57:33     INFO -      Found by: call frame info
20:57:33     INFO -  10  libxul.so!webrender::device::gl::UploadTarget::update_impl [gl.rs:d22f07a8f0f9e2f349e0b366f5207c39f0208496 : 3469 + 0x1d]
20:57:33     INFO -       sp = 0xc6ffeed8    pc = 0xd3077a19
20:57:33     INFO -      Found by: stack scanning

Not really sure why this is happening but it's something we'll need to fix. Note that the debug build crash stacks are slightly better (less inlining) than the opt build crash stacks.

I don't yet have patches landed that will allow reproducing this locally but I'll update this bug with STR once I do.

Apparently I filed this twice. Forward-duping to the more current bug

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1559834
You need to log in before you can comment on or make changes to this bug.