Closed Bug 1558199 Opened 2 years ago Closed 2 years ago

Latest Firefox nightly crashes on startup on Ubuntu Disco x86_64 (in safe mode)

Categories

(Firefox :: General, defect)

67 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1556911

People

(Reporter: slandden, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

started firefox (in safe mode)

Actual results:

Thread 33 "Socket Thread" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffe5bc2700 (LWP 18909)]
0x00007ffff09dd491 in nsObserverService::AddObserver(nsIObserver*, char const*, bool) ()
from /home/shawn/bin/firefox-bin/libxul.so
(gdb) bt
#0 0x00007ffff09dd491 in nsObserverService::AddObserver(nsIObserver*, char const*, bool) ()
at /home/shawn/bin/firefox-bin/libxul.so
#1 0x00007fffecfd363b in mozilla::net::NetworkConnectivityService::Init() () at /home/shawn/bin/firefox-bin/libxul.so
#2 0x00007fffecfd3553 in mozilla::net::NetworkConnectivityService::GetSingleton() ()
at /home/shawn/bin/firefox-bin/libxul.so
#3 0x00007fffed041e50 in nsHostResolver::TrrLookup(nsHostRecord*, mozilla::net::TRR*) ()
at /home/shawn/bin/firefox-bin/libxul.so
#4 0x00007ffff0ab10c5 in nsHostResolver::NameLookup(nsHostRecord*) () at /home/shawn/bin/firefox-bin/libxul.so
#5 0x00007ffff0aaf89d in nsHostResolver::ResolveHost(nsTSubstring<char> const&, unsigned short, mozilla::OriginAttributes const&, unsigned short, unsigned short, nsResolveHostCallback*) () at /home/shawn/bin/firefox-bin/libxul.so
#6 0x00007ffff0aba0b7 in nsDNSService::AsyncResolveInternal(nsTSubstring<char> const&, unsigned short, unsigned int, nsIDNSListener*, nsIEventTarget*, mozilla::OriginAttributes const&, nsICancelable**) ()
at /home/shawn/bin/firefox-bin/libxul.so
#7 0x00007ffff0aba61a in nsDNSService::AsyncResolveNative(nsTSubstring<char> const&, unsigned int, nsIDNSListener*, nsIEventTarget*, mozilla::OriginAttributes const&, nsICancelable**) () at /home/shawn/bin/firefox-bin/libxul.so
#8 0x00007ffff0a8f1a5 in mozilla::net::nsSocketTransport::ResolveHost() () at /home/shawn/bin/firefox-bin/libxul.so
#9 0x00007ffff0a92cf0 in mozilla::net::nsSocketTransport::OnSocketEvent(unsigned int, nsresult, nsISupports*) ()
at /home/shawn/bin/firefox-bin/libxul.so
#10 0x00007ffff0a9e72a in mozilla::net::nsSocketEvent::Run() () at /home/shawn/bin/firefox-bin/libxul.so
#11 0x00007ffff0363771 in nsThread::ProcessNextEvent(bool, bool*) () at /home/shawn/bin/firefox-bin/libxul.so
#12 0x00007ffff0364e36 in NS_ProcessNextEvent(nsIThread*, bool) () at /home/shawn/bin/firefox-bin/libxul.so
#13 0x00007ffff0376498 in mozilla::net::nsSocketTransportService::Run() () at /home/shawn/bin/firefox-bin/libxul.so
#14 0x00007ffff0a97b3d in non-virtual thunk to mozilla::net::nsSocketTransportService::Run() ()
at /home/shawn/bin/firefox-bin/libxul.so
#15 0x00007ffff0363771 in nsThread::ProcessNextEvent(bool, bool*) () at /home/shawn/bin/firefox-bin/libxul.so

Expected results:

worked

Hi Shawn - If there is a crash reports in about:crashes can you please include it here? thanks.

Flags: needinfo?(slandden)

I reported thjis with a crash report,. but this bugzilla bug prevented me from finding this to update it. https://bugzilla.mozilla.org/show_bug.cgi?id=1552383#c2

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(slandden)
Resolution: --- → DUPLICATE
Duplicate of bug: 1552383

Not a dup of Bug 1552383.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

I couldn't look up the other bug because of that bug.....

Tried to reproduce this issue on Ubuntu 18.04.2 LTS on latest nightly 69.0a1 from 14th of June - but without success.
I will add a component to it and if isn't the right one please fell free to change it.

Component: Untriaged → General
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1556911
Duplicate of this bug: 1558222
You need to log in before you can comment on or make changes to this bug.