Improve debug line highlight for arrays and objects.

RESOLVED FIXED in Firefox 69

Status

defect
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: bmiriam1230, Assigned: bmiriam1230)

Tracking

67 Branch
Firefox 69
Points:
---

Firefox Tracking Flags

(firefox69 fixed)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36

Steps to reproduce:

Steps to reproduce:

  1. Go to https://array-obj-highlighting.glitch.me/
  2. Set breakpoint on line 2.
  3. Pause on breakpoint.
  4. Repeat but set breakpoint on line 13 to test with an object.
  5. Repeat on lines 7 and 18 to view examples with column breakpoints.

Actual results:

Only the opening array bracket or object brace is highlighted. See attachment.

Expected results:

This bug was caused by recent changes to the highlight rules for debug lines which highlight from the beginning of the token starting directly after the breakpoint/column breakpoint, to the end of the token:

https://bugzilla.mozilla.org/show_bug.cgi?id=1537740

Jason proposed highlighting from the opening brace/bracket to the end of the line in the case of arrays and objects which is easier to see and understand. The change also creates parity with Chrome's highlight behavior.

Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2e033313872
For arrays and objects, highlight from token to end of line when paused.
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Assignee: nobody → bmiriam1230
You need to log in before you can comment on or make changes to this bug.