Closed Bug 1558282 Opened 5 months ago Closed 5 months ago

unsymbolicated libxul.so crash signatures from GeckoView 68 Beta

Categories

(Release Engineering :: Release Automation: Other, defect)

Unspecified
Android
defect
Not set

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox67 unaffected, firefox67.0.1 unaffected, firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: cpeterson, Assigned: jlorenzo)

References

(Regression)

Details

(Whiteboard: [geckoview:fenix:m6])

Crash Data

Attachments

(2 files)

I see some new unsymbolicated libxul.so crash signatures from GeckoView in Fenix like libxul.so@0xaae770 | libxul.so@0xdfc4bc. The first appearance of these libxul.so signatures was on 2019-06-06.

https://crash-stats.mozilla.com/topcrashers/?product=Fenix&version=68.0b0

Could the new on-demand GeckoView Beta build process have caused a problem uploading GV Beta symbols to Socorro?

Flags: needinfo?(jlorenzo)

Thank you for spotting this bug Chris. I confirm bug 1555959 is the root cause. For instance in [1], geckoview is shipped, but the jobs uploading the symbols (SymN) are missing. The reason is: these jobs aren't triggered if the commit message has DONTBUILD on it. I see how to fix this.

[1] https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=7bc83a8b0212f4aeec916f83ec8c5d5bbd9c8548

Assignee: nobody → jlorenzo
Flags: needinfo?(jlorenzo)
Regressed by: 1555959
See Also: 1555959
Summary: unsymbolicated libxul.so crash signatures from GeckoView 68 Beta? → unsymbolicated libxul.so crash signatures from GeckoView 68 Beta

I just landed the patch with DONTBUILD in order to reproduce the exact same setup. I then triggered a new geckoview shipment. Please let me know if you still see missing crash signatures.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1562273
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/552dedefb9cc
Bring opt-upload-symbol jobs when shipping geckoview r=Callek
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e2a1dfb66689
Backed out changeset 552dedefb9cc for causing linting failure in /builds/worker/checkouts/gecko/taskcluster/taskgraph/target_tasks.py CLOSED TREE
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bc899c83d978
Bring opt-upload-symbol jobs when shipping geckoview r=Callek

Oops! Done.

Flags: needinfo?(jlorenzo)
Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED

68=wontfix. I don't think we need to uplift this fix for GeckoView 68 Beta because the unsymbolicated libxul.so crash rate is pretty low and Fenix will update from GeckoView 68 to 69 Beta soon (probably 2019-07-17 when the next Fenix sprint starts).

Crash Signature: [@ libxul.so@0xaae770 | libxul.so@0xdfc4bc] → [@ libxul.so@0xaae770 | libxul.so@0xdfc4bc] [@ libxul.so@0xaae770 | libxul.so@0xdfc4bc | dalvik-main space (region space) (deleted)@0x1d9c274f ]

Sorry for the confusion, that was fixed in 68 per comment 3.

Blocks: 1563212
No longer blocks: 1563212
Regressions: 1563212
You need to log in before you can comment on or make changes to this bug.