Closed Bug 1558326 Opened 7 months ago Closed 3 months ago

OSX Mojave (10.14) - toolkit/mozapps/extensions/test/xpinstall/browser_block_fullscreen_prompt.js | Uncaught exception - TypeError: The expression cannot be converted to return the specified type.

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mixedpuppy)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

Filed by: egao [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=250956836&repo=try
Full log: https://queue.taskcluster.net/v1/task/OCn3FMk8Q5GqrzXCra9H5Q/runs/0/artifacts/public/logs/live_backing.log


Platform: macosx1014-mojave

Context:
17:00:41 INFO - TEST-START | toolkit/mozapps/extensions/test/xpinstall/browser_block_fullscreen_prompt.js
17:00:45 INFO - GECKO(2181) | Sending InstallTriggered
17:00:45 INFO - TEST-INFO | started process screencapture
17:00:45 INFO - TEST-INFO | screencapture: exit 0
17:00:45 INFO - Buffered messages logged at 17:00:41
17:00:45 INFO - Entering test bound testFullscreenBlockAddonInstallPrompt
17:00:45 INFO - Buffered messages logged at 17:00:44
17:00:45 INFO - TEST-PASS | toolkit/mozapps/extensions/test/xpinstall/browser_block_fullscreen_prompt.js | Addon installation prompt not opened -
17:00:45 INFO - Leaving test bound testFullscreenBlockAddonInstallPrompt
17:00:45 INFO - Entering test bound testFullscreenCloseAddonInstallPrompt
17:00:45 INFO - Console message: [JavaScript Warning: "Exited fullscreen because fullscreen element was removed from document." {file: "chrome://browser/content/tabbrowser.js" line: 3152}]
17:00:45 INFO - Buffered messages logged at 17:00:45
17:00:45 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22XPI%22%3A%22amosigned.xpi%22%7D" line: 0}]
17:00:45 INFO - TEST-PASS | toolkit/mozapps/extensions/test/xpinstall/browser_block_fullscreen_prompt.js | Opened notification is installation blocked prompt - true == true -
17:00:45 INFO - Buffered messages finished
17:00:45 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/xpinstall/browser_block_fullscreen_prompt.js | Uncaught exception - TypeError: The expression cannot be converted to return the specified type.
17:00:45 INFO - Leaving test bound testFullscreenCloseAddonInstallPrompt
17:00:45 INFO - Console message: [JavaScript Warning: "Request for fullscreen was denied because requesting element is not in the currently focused tab." {file: "http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22XPI%22%3A%22amosigned.xpi%22%7D" line: 0}]
17:00:45 INFO - GECKO(2181) | MEMORY STAT | vsize 7674MB | residentFast 404MB | heapAllocated 154MB
17:00:45 INFO - TEST-OK | toolkit/mozapps/extensions/test/xpinstall/browser_block_fullscreen_prompt.js | took 3273ms
17:00:45 INFO - Not taking screenshot here: see the one that was previously logged
17:00:45 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/xpinstall/browser_block_fullscreen_prompt.js | Found an unexpected tab at the end of test run: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/installtrigger.html?%7B%22XPI%22%3A%22amosigned.xpi%22%7D -
17:00:45 INFO - GECKO(2181) | 1560186045249 addons.manager WARN InstallListener threw exception when calling onDownloadCancelled: TypeError: this.webProgress is null(chrome://global/content/elements/browser-custom-element.js:929:5) JS Stack trace: removeProgressListener@browser-custom-element.js:929:5
17:00:45 INFO - GECKO(2181) | unregister@AddonManager.jsm:283:20
17:00:45 INFO - GECKO(2181) | onDownloadCancelled@AddonManager.jsm:315:10
17:00:45 INFO - GECKO(2181) | callInstallListeners@AddonManager.jsm:1361:33
17:00:45 INFO - GECKO(2181) | callInstallListeners@AddonManager.jsm:2862:54
17:00:45 INFO - GECKO(2181) | _callInstallListeners@XPIInstall.jsm:1757:32
17:00:45 INFO - GECKO(2181) | cancel@XPIInstall.jsm:1252:12
17:00:45 INFO - GECKO(2181) | cancel@XPIInstall.jsm:1939:13
17:00:45 INFO - GECKO(2181) | cancel@XPIInstall.jsm:2377:22
17:00:45 INFO - GECKO(2181) | cancelInstall@AddonManager.jsm:291:20
17:00:45 INFO - GECKO(2181) | observe@AddonManager.jsm:303:10
17:00:45 INFO - GECKO(2181) | _endRemoveTab@tabbrowser.js:3152:13
17:00:45 INFO - GECKO(2181) | removeTab@tabbrowser.js:2849:12
17:00:45 INFO - GECKO(2181) | Tester_waitForWindowsState@browser-test.js:577:18
17:00:45 INFO - GECKO(2181) | nextTest@browser-test.js:911:10
17:00:45 INFO - GECKO(2181) | asynctestScope/test_finish/<@browser-test.js:1416:25
17:00:45 INFO - GECKO(2181) | run@browser-test.js:1353:9
17:00:45 INFO - checking window state
17:00:45 INFO - Console message: 1560186045249 addons.manager WARN InstallListener threw exception when calling onDownloadCancelled: TypeError: this.webProgress is null(chrome://global/content/elements/browser-custom-element.js:929:5) JS Stack trace: removeProgressListener@browser-custom-element.js:929:5
17:00:45 INFO - unregister@AddonManager.jsm:283:20
17:00:45 INFO - onDownloadCancelled@AddonManager.jsm:315:10
17:00:45 INFO - callInstallListeners@AddonManager.jsm:1361:33
17:00:45 INFO - callInstallListeners@AddonManager.jsm:2862:54
17:00:45 INFO - _callInstallListeners@XPIInstall.jsm:1757:32
17:00:45 INFO - cancel@XPIInstall.jsm:1252:12
17:00:45 INFO - cancel@XPIInstall.jsm:1939:13
17:00:45 INFO - cancel@XPIInstall.jsm:2377:22
17:00:45 INFO - cancelInstall@AddonManager.jsm:291:20
17:00:45 INFO - observe@AddonManager.jsm:303:10
17:00:45 INFO - _endRemoveTab@tabbrowser.js:3152:13
17:00:45 INFO - removeTab@tabbrowser.js:2849:12
17:00:45 INFO - Tester_waitForWindowsState@browser-test.js:577:18
17:00:45 INFO - nextTest@browser-test.js:911:10
17:00:45 INFO - async
testScope/test_finish/<@browser-test.js:1416:25
17:00:45 INFO - run@browser-test.js:1353:9

:ddurst - this is a new failure observed on macosx1014. Could you pass the ni to someone who may be able to investigate or provide feedback on if the test can/should be disabled for macosx1014?

Flags: needinfo?(ddurst)

If this is not intermittent, then let's not hide it from triage. Also, it's marked as a regression: can we get a range?

Flags: needinfo?(ddurst) → needinfo?(egao)
Priority: P5 → --
Flags: needinfo?(egao)

I have corrected the tagging - it is an intermittent issue.

The priority flag is not set for this bug.
:ddurst, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(ddurst)

:ddurst - this is continuing to fail for mochitest-browser-chrome whyen run against macosx 10.14 and 10.14.5. While it may have been intermittent for other platforms prior to this, for macosx 10.14.x it appears to be a permafail.

Flags: needinfo?(ddurst) → needinfo?(jmathies)
Flags: needinfo?(jmathies)
Whiteboard: webext?
Flags: needinfo?(mixedpuppy)
Assignee: nobody → mixedpuppy
Flags: needinfo?(mixedpuppy)
Priority: -- → P3
Priority: P3 → P1
Whiteboard: webext?

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:mixedpuppy, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mixedpuppy)
Attachment #9086545 - Attachment is obsolete: true

Bug 1505916 probably fixed this, we just need to enable it for osx.

Flags: needinfo?(mixedpuppy)
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c11aa23a0639
re-enable test browser_block_fullscreen_prompt.js r=robwu
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
See Also: → 1590136
You need to log in before you can comment on or make changes to this bug.