Closed Bug 1558337 Opened 1 year ago Closed 1 year ago

click-and-hold context menus do not appear when touch simulation enabled (TypeError popup is null)

Categories

(DevTools :: Responsive Design Mode, defect, P2)

defect

Tracking

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 verified)

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- verified

People

(Reporter: bradwerth, Assigned: mconley)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Appears to be a regression caused by landing of Bug 1505909. Steps to reproduce:

  1. Set pref "ui.click_hold_context_menus" to true.
  2. Navigate to any site, and open Responsive Design Mode.
  3. Turn touch simulation on (UI widget in RDM toolbar should be lit).
  4. Click and hold on RDM content.

Expected results:
Context menu should appear.

Actual results:
Browser Console error message: JavaScript error: chrome://browser/content/nsContextMenu.js, line 97: TypeError: popup is null.

Note that right-click or modifier-key click still works to make context menu appear.

Flags: needinfo?(mconley)
Blocks: 1390793

Thanks for filing. Looking.

Assignee: nobody → mconley
Blocks: 1558119
Priority: -- → P2

This workaround hands the top-level browser to nsContextMenu rather than the
mozbrowser in the RDM case. We need to do that since RDM does a lot of work
to make the inner mozbrowser seem like the top-level browser, including
proxying messages from that top-most browser to the underlying mozbrowser.

This workaround makes us consistent with that model, and will have to do until
we can get bug 1559456 fixed.

Depends on D35077

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/18dee3d299c1
Add a workaround for RDM for ContextMenuParent.jsm to make context menus work properly. r=NeilDeakin
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Flags: qe-verify+

Hello,
Reproduced the issue using Firefox 69.0a1 (20190610214846) on Windows 10x64.
The issue is verified fixed with Firefox 69.0b7 (20190722201635) on Windows 10x64, macOS 10.14 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.