Closed Bug 1558348 Opened 3 months ago Closed 3 months ago

Intermittent toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js | xpcshell return code: 1

Categories

(WebExtensions :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1557292

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, regression)

Filed by: nerli [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=250995746&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/fRJ5l16LRPyT9wOvWCgw7w/runs/0/artifacts/public/logs/live_backing.log


21:15:29 INFO - TEST-START | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js
21:15:31 WARNING - TEST-UNEXPECTED-FAIL | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js | xpcshell return code: 1
21:15:31 INFO - TEST-INFO took 1922ms
21:15:31 INFO - >>>>>>>
21:15:31 INFO - PID 4464 | [4464, Main Thread] WARNING: Couldn't get the user appdata directory. Crash events may not be produced.: file /builds/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2514
21:15:31 INFO - PID 4464 | [4464, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, kKnownEsrVersion) failed with result 0x80004002: file /builds/worker/workspace/build/src/toolkit/components/resistfingerprinting/nsRFPService.cpp, line 662
21:15:31 INFO - PID 4464 | [4464, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file /builds/worker/workspace/build/src/extensions/permissions/nsPermissionManager.cpp, line 2903
21:15:31 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
21:15:31 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
21:15:31 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)
21:15:31 INFO - running event loop
21:15:31 INFO - xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js | Starting check_remote
21:15:31 INFO - (xpcshell/head.js) | test check_remote pending (2)
21:15:31 INFO - TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js | check_remote - [check_remote : 1] useRemoteWebExtensions matches - true == true
21:15:31 INFO - TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js | check_remote - [check_remote : 1] testing from extension process - false == false
21:15:31 INFO - (xpcshell/head.js) | test run_next_test 0 finished (2)
21:15:31 INFO - (xpcshell/head.js) | test run_next_test 1 pending (2)
21:15:31 INFO - (xpcshell/head.js) | test check_remote finished (2)
21:15:31 INFO - xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js | Starting setup
21:15:31 INFO - (xpcshell/head.js) | test setup pending (2)
21:15:31 INFO - (xpcshell/head.js) | test run_next_test 1 finished (2)
21:15:31 INFO - (xpcshell/head.js) | test run_next_test 2 pending (2)
21:15:31 INFO - (xpcshell/head.js) | test setup finished (2)
21:15:31 INFO - xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js | Starting test_captivePortal_basic
21:15:31 INFO - (xpcshell/head.js) | test test_captivePortal_basic pending (2)
21:15:31 INFO - "Extension attached"
21:15:31 INFO - (xpcshell/head.js) | test run_next_test 2 finished (2)
21:15:31 INFO - PID 4464 | ++DOCSHELL 0x11be67800 == 1 [pid = 4464] [id = {0bfff88e-0843-2449-af93-0773cacbcae6}]
21:15:31 INFO - PID 4464 | ++DOMWINDOW == 1 (0x1170c4020) [pid = 4464] [serial = 1] [outer = 0x0]
21:15:31 INFO - PID 4464 | ++DOMWINDOW == 2 (0x11bec6000) [pid = 4464] [serial = 2] [outer = 0x1170c4020]
21:15:31 INFO - PID 4464 | ++DOMWINDOW == 3 (0x11c5d0400) [pid = 4464] [serial = 3] [outer = 0x1170c4020]
21:15:31 INFO - PID 4464 | [Parent 4464, Main Thread] WARNING: Couldn't get the user appdata directory, crash dumps will go in an unusual location: file /builds/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2584
21:15:31 INFO - PID 4464 | [4465, MainThread] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/worker/workspace/build/src/xpcom/base/nsTraceRefcnt.cpp, line 194
21:15:31 INFO - PID 4464 | [4465, MainThread] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/worker/workspace/build/src/xpcom/base/nsTraceRefcnt.cpp, line 194
21:15:31 INFO - PID 4464 | [Parent 4464, GMPThread] WARNING: Failed to delete GMP storage directory: file /builds/worker/workspace/build/src/dom/media/gmp/GMPServiceParent.cpp, line 1571
21:15:31 INFO - PID 4464 | [Parent 4464, Main Thread] WARNING: Need BrowserChild to get the nativeWindow from!: file /builds/worker/workspace/build/src/widget/PuppetWidget.cpp, line 1096
21:15:31 INFO - PID 4464 | ++DOCSHELL 0x11c4d2800 == 1 [pid = 4465] [id = {18c6511f-b004-5a4b-9dca-ff5ef701a25a}]
21:15:31 INFO - PID 4464 | ++DOMWINDOW == 1 (0x12342a020) [pid = 4465] [serial = 1] [outer = 0x0]
21:15:31 INFO - PID 4464 | [Child 4465, Main Thread] WARNING: Fallback to BasicLayerManager: file /builds/worker/workspace/build/src/dom/ipc/BrowserChild.cpp, line 2633
21:15:31 INFO - PID 4464 | [Child 4465, Main Thread] WARNING: No active window: file /builds/worker/workspace/build/src/js/xpconnect/src/XPCJSContext.cpp, line 662
21:15:31 INFO - PID 4464 | ++DOMWINDOW == 2 (0x11c492800) [pid = 4465] [serial = 2] [outer = 0x12342a020]
21:15:31 INFO - PID 4464 | ++DOMWINDOW == 3 (0x1234c8000) [pid = 4465] [serial = 3] [outer = 0x12342a020]
21:15:31 INFO - TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js | test_captivePortal_basic - [test_captivePortal_basic : 317] initial state unknown - Expected: unknown, Actual: unknown - true == true
21:15:31 INFO - PID 4464 | Assertion failure: peerAddr.Contains(':') || ((bool)(__builtin_expect(!!(NS_FAILED_impl(aStatusCode)), 0))), at /builds/worker/workspace/build/src/netwerk/base/NetworkConnectivityService.cpp:281
21:16:00 INFO - PID 4464 | #01: non-virtual thunk to mozilla::net::NetworkConnectivityService::OnStopRequest(nsIRequest*, nsresult) [netwerk/base/NetworkConnectivityService.cpp:0]
21:16:00 INFO - PID 4464 | #02: mozilla::net::nsHttpChannel::ContinueOnStopRequest(nsresult, bool, bool) [netwerk/protocol/http/nsHttpChannel.cpp:8194]
21:16:00 INFO - PID 4464 | #03: mozilla::net::nsHttpChannel::ContinueOnStopRequestAfterAuthRetry(nsresult, bool, bool, bool, mozilla::net::nsHttpTransaction*) [netwerk/protocol/http/nsHttpChannel.cpp:8022]
21:16:00 INFO - PID 4464 | #04: mozilla::net::nsHttpChannel::OnStopRequest(nsIRequest*, nsresult) [netwerk/protocol/http/nsHttpChannel.cpp:7956]
21:16:00 INFO - PID 4464 | #05: nsInputStreamPump::OnStateStop() [netwerk/base/nsInputStreamPump.cpp:656]
21:16:00 INFO - PID 4464 | #06: nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) [netwerk/base/nsInputStreamPump.cpp:412]
21:16:00 INFO - PID 4464 | #07: non-virtual thunk to nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) [netwerk/base/nsInputStreamPump.cpp:0]
21:16:00 INFO - PID 4464 | #08: nsInputStreamReadyEvent::Run() [xpcom/io/nsStreamUtils.cpp:93]
21:16:00 INFO - PID 4464 | #09: nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:1165]
21:16:00 INFO - PID 4464 | #10: nsThreadManager::SpinEventLoopUntilInternal(nsINestedEventLoopCondition*, bool) [xpcom/threads/nsThreadManager.cpp:488]
21:16:00 INFO - PID 4464 | Exiting due to channel error.
21:16:00 INFO - <<<<<<<
21:16:00 INFO - mozcrash Copy/paste: /Users/cltbld/tasks/task_1560199337/build/macosx64-minidump_stackwalk /var/folders/vw/j0l9hjbd6k7gml24_127s_n000000x/T/xpc-other-8JKIo4/86BF8AF9-509E-435F-BD78-1931AEC547F4.dmp /Users/cltbld/tasks/task_1560199337/build/symbols
21:16:08 INFO - mozcrash Saved minidump as /Users/cltbld/tasks/task_1560199337/build/blobber_upload_dir/86BF8AF9-509E-435F-BD78-1931AEC547F4.dmp
21:16:08 INFO - mozcrash Saved app info as /Users/cltbld/tasks/task_1560199337/build/blobber_upload_dir/86BF8AF9-509E-435F-BD78-1931AEC547F4.extra
21:16:08 WARNING - PROCESS-CRASH | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_captivePortal.js | application crashed [@ mozilla::net::NetworkConnectivityService::OnStopRequest(nsIRequest*, nsresult)]
21:16:08 INFO - Crash dump filename: /var/folders/vw/j0l9hjbd6k7gml24_127s_n000000x/T/xpc-other-8JKIo4/86BF8AF9-509E-435F-BD78-1931AEC547F4.dmp
21:16:08 INFO - Operating system: Mac OS X
21:16:08 INFO - 10.10.5 14F27
21:16:08 INFO - CPU: amd64
21:16:08 INFO - family 6 model 69 stepping 1
21:16:08 INFO - 4 CPUs
21:16:08 INFO - GPU: UNKNOWN
21:16:08 INFO - Crash reason: EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
21:16:08 INFO - Crash address: 0x0
21:16:08 INFO - Process uptime: 2 seconds
21:16:08 INFO - Thread 0 (crashed)
21:16:08 INFO - 0 XUL!mozilla::net::NetworkConnectivityService::OnStopRequest(nsIRequest*, nsresult) [NetworkConnectivityService.cpp:79e19fcebe123b7739103b1b5485f691b92f9176 : 281 + 0x29]
21:16:08 INFO - rax = 0x00000001105d293d rdx = 0x00007fff7a6261f8
21:16:08 INFO - rcx = 0x00000001123f0d60 rbx = 0x00007fff571d1408
21:16:08 INFO - rsi = 0x0000260000002600 rdi = 0x0000250000002603
21:16:08 INFO - rbp = 0x00007fff571d1490 rsp = 0x00007fff571d13f0
21:16:08 INFO - r8 = 0x00007fff571d13a0 r9 = 0x00007fff789e9300
21:16:08 INFO - r10 = 0x0000000108e91870 r11 = 0x0000000108e917d0
21:16:08 INFO - r12 = 0x0000000000000000 r13 = 0x0000000000000001
21:16:08 INFO - r14 = 0x00000001170b1088 r15 = 0x00000001170b1040
21:16:08 INFO - rip = 0x0000000108f4489d
21:16:08 INFO - Found by: given as instruction pointer in context
21:16:08 INFO - 1 XUL!non-virtual thunk to mozilla::net::NetworkConnectivityService::OnStopRequest(nsIRequest*, nsresult) [NetworkConnectivityService.cpp:79e19fcebe123b7739103b1b5485f691b92f9176 : 0 + 0xd]
21:16:08 INFO - rbp = 0x00007fff571d14a0 rsp = 0x00007fff571d14a0
21:16:08 INFO - rip = 0x0000000108f448bd
21:16:08 INFO - Found by: previous frame's frame pointer
21:16:08 INFO - 2 XUL!mozilla::net::nsHttpChannel::ContinueOnStopRequest(nsresult, bool, bool) [nsHttpChannel.cpp:79e19fcebe123b7739103b1b5485f691b92f9176 : 8192 + 0x1d]
21:16:08 INFO - rbp = 0x00007fff571d1520 rsp = 0x00007fff571d14b0
21:16:08 INFO - rip = 0x0000000109410520
21:16:08 INFO - Found by: previous frame's frame pointer

My changes have nothing to do with this crash.

This crash already occurred even before my patches landed: bug 1557292

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(rob)
No longer regressed by: 1551490
Resolution: --- → DUPLICATE
Duplicate of bug: 1557292
You need to log in before you can comment on or make changes to this bug.