when retrieving certain messages from IMAP server the mail read hangs forever

RESOLVED WORKSFORME

Status

MailNews Core
MIME
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Alexei, Assigned: Cavin Song)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

I recieve messages from a mailing list daily. Almost 90% of those messages hang
the mail reader. Status 'Loading Document' is displayed, the blue indicator on
the bottom of the window is moving, but the message  is not retrieved.
Sometimes, after a while the window wakes up and displays first two lines of the
message. I ran a sniffer, and found out the the message is actually transmitted
by the server in full. This problem also occurs in Netscape 6.2.3, but does not
occur with Netscape 4.78

Reproducible: Always
Steps to Reproduce:
1.open mail
2.choose the folder where the message is located
3.try to open the messag by selecting it

Actual Results:  mail window goes into "I am working here" mode and stays there

Expected Results:  displayed the message

here is IMAP capture with the message, for your enjoyment: 

* 3 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 1025324561] UID validity status
* OK [UIDNEXT 9] Predicted next UID
* FLAGS (\Answered \Flagged \Deleted \Draft \Seen)
* OK [PERMANENTFLAGS (\* \Answered \Flagged \Deleted \Draft \Seen)] Permanent flags
53 OK [READ-WRITE] SELECT completed
* 1 FETCH (UID 5 FLAGS (\Seen))
* 2 FETCH (UID 7 FLAGS (\Seen))
* 3 FETCH (UID 8 FLAGS (\Seen))
54 OK UID FETCH completed
* 2 FETCH (UID 7 RFC822.SIZE 12951 BODY[] {12951}
Received: via dmail-2000(11) for barski+mail/sight-new; Thu, 4 Jul 2002 14:04:27
-0700 (PDT)
Received: from sight ([217.106.231.239])
	by domovoy.com (8.11.6/8.11.6) with ESMTP id g64L4OW15456
	for <ab_sight@domovoy.com>; Thu, 4 Jul 2002 14:04:25 -0700
Received: from leesin by sight with local (Exim 3.35 #1 (Debian))
	id 17QDkI-0001w0-00
	for <ab_sight@domovoy.com>; Fri, 05 Jul 2002 01:02:34 +0400
To: ab_sight@domovoy.com
Subject: Фото.Сайт. Новые фотографии Любимых авторов
From: dmilee@sight.ru
X-Mailer: PHP/4.2.1
Content-type: text/html; charset=koi8-r
Message-Id: <E17QDkI-0001w0-00@sight>
Sender: <leesin@photosight.ru>
Date: Fri, 05 Jul 2002 01:02:34 +0400


<html><head><title>Фото.Сайт - рассылка</title><meta http-equiv='Content-Type'
content='text/html; charset=koi8-r'></head>
        <BODY bgcolor=#eeeee0 text=black link=blue alink=red vlink=blue>
Уважаемый kobian,<br><br>Новые фотографии ваших любимых авторов:<br>
<table border="0" cellpadding="10" cellspacing="5"><table border="0"
cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=455"><b>Алексей Тихонов
</b></a><table border="0" cellpadding="10" cellspacing="5"><tr
bgcolor="#EEEEEE"><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020704_205357_alt&cat=c">борьба
за мяч</a></td><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020704_015818_alt&cat=c">вроде
не гол</a></td></tr></table><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=1100"><b>шмыг</b></a><table
border="0" cellpadding="10" cellspacing="5"><tr bgcolor="#EEEEEE"><td
width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=920020704_030131_cloud9&cat=9">алё</a></td></tr></table><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=513"><b>Александр
Колбунов</b></a><table border="0" cellpadding="10" cellspacing="5"><tr
bgcolor="#EEEEEE"><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020704_141119_irsy&cat=c">Ритмы
южного солнца</a></td></tr></table><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=184"><b>Oleg Pylaev</b></a><table
border="0" cellpadding="10" cellspacing="5"><tr bgcolor="#EEEEEE"><td
width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020704_150214_olegator&cat=c">Читать</a></td><td
width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020704_150205_olegator&cat=c">Играть</a></td></tr></table><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=4218"><b>VLV</b></a><table
border="0" cellpadding="10" cellspacing="5"><tr bgcolor="#EEEEEE"><td
width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020705_004753_vvandalovsky&cat=c">СЛУШАЯ
ДЖАЗ-7 (серия)</a></td><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020705_003459_vvandalovsky&cat=c">СЛУШАЯ
ДЖАЗ -6(серия)</a></td><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020705_001456_vvandalovsky&cat=c">СЛУШАЯ
ДЖАЗ-5 (серия)</a></td></tr></table><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=1327"><b>Андрей
Меньших</b></a><table border="0" cellpadding="10" cellspacing="5"><tr
bgcolor="#EEEEEE"><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=120020704_212529_menchikh&cat=1">Мурка</a></td></tr></table><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=9314"><b>Ираклий
Шанидзе</b></a><table border="0" cellpadding="10" cellspacing="5"><tr
bgcolor="#EEEEEE"><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=a20020704_074913_irakly&cat=a">Cirque
Du Soleil. Myster&#233;</a></td><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=a20020704_071326_irakly&cat=a">Cirque
Du Soleil. Myster&#233;</a></td><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=920020704_044141_irakly&cat=9">Ой,
горе... Карточка для семейного альбома</a></td></tr></table><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=1599"><b>Sergey
Ponomarev</b></a><table border="0" cellpadding="10" cellspacing="5"><tr
bgcolor="#EEEEEE"><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=a20020704_181846_maroot&cat=a">Вода
Сошла. Последняя. Му-Му.</a></td></tr></table><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=888"><b>Sergey
Bachlakov</b></a><table border="0" cellpadding="10" cellspacing="5"><tr
bgcolor="#EEEEEE"><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=920020704_081711_bsg85&cat=9">Images
of Jazz: #4</a></td><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=920020704_080038_bsg85&cat=9">Electronica</a></td><td
width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=920020704_075325_bsg85&cat=9">Images
of Jazz: #3</a></td></tr></table><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=16244"><b>simka</b></a><table
border="0" cellpadding="10" cellspacing="5"><tr bgcolor="#EEEEEE"><td
width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=x20020704_233834_sima108&cat=x"></a></td><td
width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020704_233404_sima108&cat=c">prosto
v tramvae</a></td><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=920020704_233111_sima108&cat=c">*****
  .......       to Roy Celine</a></td><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020704_232146_sima108&cat=c">Spiderman</a></td><td
width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=120020704_231627_sima108&cat=1">Irka
i Max</a></td></tr></table><table border="0" cellpadding="10"
cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=12210"><b>Oxana
Diakonashvili</b></a><table border="0" cellpadding="10" cellspacing="5"><tr
bgcolor="#EEEEEE"><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=920020704_003223_oxana&cat=9">sidewalk</a></td></tr></table><table
border="0" cellpadding="10" cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=12671"><b>sonson</b></a><table
border="0" cellpadding="10" cellspacing="5"><tr bgcolor="#EEEEEE"><td
width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020704_002048_sonson&cat=c">TEATR</a></td></tr></table><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><table border="0" cellpadding="10"
cellspacing="5"><table border="0" cellpadding="10" cellspacing="5"><table
border="0" cellpadding="10" cellspacing="5"><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=4058"><b>consttt
linoleum</b></a><table border="0" cellpadding="10" cellspacing="5"><tr
bgcolor="#EEEEEE"><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=920020705_000919_consttt&cat=9">h
o p</a></td></tr></table><br><br><a
href="http://www.photosight.ru/ownpage.emax?id=2043"><b>Евгений Гучкин
(Guk)</b></a><table border="0" cellpadding="10" cellspacing="5"><tr
bgcolor="#EEEEEE"><td width="100" align="center"><a
href="http://www.photosight.ru/photo.emax?pic=c20020704_000931_Guchka&cat=c">На
плоту</a></td></tr></table>
<br><br>
Для изменения условий подписки зайдите на фото.сайт в раздел <a
href='http://www.photosight.ru/my.emax' target=_blank>МОЁ!</a><br>
Чтобы пополнить список любимых авторов зайдите на страницу автора и отметьте
галочкой "мой любимый автор"<br>
<br>
<br>
<br><br>
<b>НОВОСТИ</b>
<br><br>
22.03.02 Компания Soligor расширяет линейку аксессуаров для цифровых камер<br>
Soligor представил новую линейку аксессуаров для цифровых фотокамер.<br>
<a href="http://dtimes.10x15.ru/news_text.10x15?id=749">подробнее>></a>
<br><br>
22.03.02 Цифровая фотокамера от Болгарского производителя<br>
На прошедшей выставке CeBIT в Ганновере болгарская компания Daisy Technology
представила компактную цифровую камеру - PhotoClip.<br>
<a href="http://dtimes.10x15.ru/news_text.10x15?id=748">подробнее>></a>
<br><br>
<b>TESTLAB</b>
<br><br>
Minolta DiMAGE 7<br>
Впервые о Minolta DiMAGE 7 заговорили в начале прошлого года. В феврале камера
была представлена на выставке PMA 2001, а в апреле ее уже можно было видеть на
стенде Minolta на российской выставке "Фотофорум"...<br>
<a href="http://dtimes.10x15.ru/testlab_text.10x15?id=33">подробнее>></a><br><br>



<br>
<br>
<a href="http://www.photosight.ru">Фото.Сайт</a><br>
www.photosight.ru
<br>
</body></html>

)
55 OK UID FETCH completed
* BYE domovoy.com IMAP4rev1 server terminating connection
56 OK LOGOUT completed

Updated

16 years ago
QA Contact: gayatri → huang
over to cavin for investigation...
Assignee: ducarroz → cavin

Comment 2

16 years ago
dupe of bug 135039?
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4 RC1)? If so, then please comment again with details. If not, then
please resolve this bug as WORKSFORME. Thanks.
(Reporter)

Comment 4

15 years ago
I do not have the setup to reproduce this bug anymore
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.