Closed Bug 1558676 Opened 1 year ago Closed 1 year ago

Intermittent toolkit/mozapps/extensions/test/browser/browser_html_options_ui.js | The height is smaller to start - Got 250, expected 301

Categories

(Toolkit :: Add-ons Manager, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: smaug)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file, 1 obsolete file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=251256661&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/ax0z1luyQfC3vx4zDEJsfA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-06-11T22:57:25.560Z] 22:57:25 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "moz-extension://a2a05a05-b054-466d-a35d-b0b512e594b1/options.html" line: 0}]
[task 2019-06-11T22:57:25.560Z] 22:57:25 INFO - Buffered messages finished
[task 2019-06-11T22:57:25.561Z] 22:57:25 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/browser/browser_html_options_ui.js | The height is smaller to start - Got 250, expected 301
[task 2019-06-11T22:57:25.561Z] 22:57:25 INFO - Stack trace:
[task 2019-06-11T22:57:25.562Z] 22:57:25 INFO - chrome://mochikit/content/browser-test.js:test_is:1324
[task 2019-06-11T22:57:25.562Z] 22:57:25 INFO - chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_html_options_ui.js:testInlineOptions:141
[task 2019-06-11T22:57:25.562Z] 22:57:25 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1115
[task 2019-06-11T22:57:25.562Z] 22:57:25 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1143
[task 2019-06-11T22:57:25.563Z] 22:57:25 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1004
[task 2019-06-11T22:57:25.563Z] 22:57:25 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-06-11T22:57:25.564Z] 22:57:25 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-06-11T22:57:25.564Z] 22:57:25 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/browser/browser_html_options_ui.js | The browser is the same size - Got 250, expected 301
[task 2019-06-11T22:57:25.565Z] 22:57:25 INFO - Stack trace:
[task 2019-06-11T22:57:25.566Z] 22:57:25 INFO - chrome://mochikit/content/browser-test.js:test_is:1324
[task 2019-06-11T22:57:25.567Z] 22:57:25 INFO - chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_html_options_ui.js:testInlineOptions:142
[task 2019-06-11T22:57:25.568Z] 22:57:25 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1115
[task 2019-06-11T22:57:25.569Z] 22:57:25 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1143
[task 2019-06-11T22:57:25.569Z] 22:57:25 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1004
[task 2019-06-11T22:57:25.570Z] 22:57:25 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-06-11T22:57:25.576Z] 22:57:25 INFO - Resize the browser to be taller
[task 2019-06-11T22:57:25.577Z] 22:57:25 INFO - GECKO(5175) | JavaScript error: resource:///actors/BrowserTabParent.jsm, line 32: TypeError: browser.ownerGlobal.gBrowserInit is undefined

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INCOMPLETE

This happens rather often on ash repository which has the preliminary session history implementation for Fission.

Assignee: nobody → bugs
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

TestUtils.waitForCondition can't be used here since it doesn't handle functions with awaits in them properly.

Attachment #9089121 - Attachment is obsolete: true
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b75df9358daa
browser_html_options_ui.js should wait long enough to ensure layout has been flushed everywhere, r=mstriemer
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Hello,

Will this fix require manual validation? If yes, please provide some steps to reproduce in order to correctly test it and also, please set the "qe-verify+" flag. Otherwise, could the "qe-verify-" flag be added? Thanks!

Flags: needinfo?(bugs)

This is about a test fix. No need for manual validation. Either the intermittent failure is fixed or it is not.

Flags: needinfo?(bugs) → qe-verify-
You need to log in before you can comment on or make changes to this bug.