Closed Bug 1558678 Opened 6 months ago Closed 6 months ago

GPU memory leak with canvas and WebRender

Categories

(Core :: Graphics: WebRender, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1558100

People

(Reporter: hwti, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

With WebRender enabled, load any page with a canvas rendering frames, for example :

I'm using Nightly with an NVIDIA GTX 970, 430.86 driver, Windows 10 1903.

Actual results:

The system Commit charge and Physical memory (until Windows memory compression is triggered) increase continuously.
The dedicated GPU memory on the GPU process seems to follow the same increase (but it periodically decreases as the dedicated memory is limited), and its handle count increases.

Switching to another tab pauses the leak.
Closing the tab doesn't free the memory, but killing the GPU process does.

See Also: → 1558100
Blocks: wr-69
Priority: -- → P2

Loïc, can you check if the problem is addressed on latest nightly?

Flags: needinfo?(hwti)

The leak seems fixed.

But both pages are broken : the canvas is only updated on screen if there is something else which changes on the page, if something is redrawn in the Firefox interface, or when scrolling.
I still see CPU and GPU usage, and the performance tab in the inspector still shows requestAnimationFrame or setTimeout events, so I assume the canvas is drawn but it doesn't trigger the composition.

Flags: needinfo?(hwti)

(In reply to Loïc Yhuel from comment #2)

But both pages are broken : the canvas is only updated on screen if there is something else which changes on the page, if something is redrawn in the Firefox interface, or when scrolling.

Thanks for the confirmation!
Hmm, I could not reproduce it on my laptop. I wonder if Bug 1559284 might be related.

(In reply to Sotaro Ikeda [:sotaro] from comment #3)

(In reply to Loïc Yhuel from comment #2)

But both pages are broken : the canvas is only updated on screen if there is something else which changes on the page, if something is redrawn in the Firefox interface, or when scrolling.

I succeeded to reproduce it with local build. When I locally backed out Bug 1558106, the problem was addressed. Then it seems dup of Bug 1559284.

See Also: → 1559284

GPU memory leak with canvas and WebRender

(In reply to Loïc Yhuel from comment #2)

The leak seems fixed.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1558100
You need to log in before you can comment on or make changes to this bug.