1.1a Installer overwrites bookmark.html... and...

RESOLVED DUPLICATE of bug 153713

Status

RESOLVED DUPLICATE of bug 153713
17 years ago
14 years ago

People

(Reporter: secooley, Assigned: bugs)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Dammit, I knew better.... I KNEW better....
(sigh)
After upgrading from 0.97 to 1.1a, my bookmark.html file was - like - gone dude...
In its place was this not so cool "standard" bookmark.html file.
What fool in the world, even *knows* what mozilla is, installs it, and doesn't
already have bookmarks? and perhaps even has mozilla bookmarks?
Sigh... 
(dammit)

Sure, it is windows.  Up until now, you guys have been super- 
outstanding in the field somewhere.

This time, I had to reboot windows (the "file" portion was totally messed up).
I installed an old copy I had lying around somewhere, and - was still messed up.
so - I renamed the program files\mozilla.org directory, just in case (this is
*after* I lost my bookmarks...)
It was still goofy after the install - so I'm guessing the reboot fixed the problem 
(windows mottttto: where does your data want to go today? or how many times do
you want to reboot today?)

Keep up the good work.  Remind me to back up my bookmarks file next time
(dammit, I can't believe I didn't...)

Stay cool -
(Reporter)

Comment 1

17 years ago
forgot to mention, did a search for bookmark.html (just in case).
I found an old copy that I had scurried away (don't know why) - so I only lost 2
months of bookmarks.... 
the most recent copy was the one I installed today (and I know that I had a more
recent copy - because I'm always finding interesting stuff that I'll never get
back to, but bookmark anyway)

Comment 2

17 years ago
WFM in build 2002070204 PC/Win98.
WFM: Win2k/2002070508.
The installer wouldn't do this, it knows nothing about profiles. If you didn't
create a new profile I can't think of any way the profile migration or new
profile code would kick in which is what would give you the default bookmarks file.

I've heard mentions of problems where the bookmarks file got corrupted (some
folks had > 100 Mb files) -- maybe the bookmark folks added code to detect the
corruption and restart the file?

-> Bookmarks
Assignee: dveditz → ben
Component: Installer → Bookmarks
QA Contact: bugzilla → claudius

Comment 5

17 years ago
Marking as dupe of bug #153713

*** This bug has been marked as a duplicate of 153713 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.