Closed Bug 1559084 Opened 2 years ago Closed 2 years ago

Use of unknown property Ci.nsIClearDataService.CLEAR_PUSH_NOTIFICATIONS

Categories

(GeckoView :: General, defect)

Unspecified
All
defect
Not set
normal

Tracking

(firefox67 unaffected, firefox68 wontfix, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox67 --- unaffected
firefox68 --- wontfix
firefox69 --- fixed

People

(Reporter: standard8, Assigned: esawin)

References

(Blocks 1 open bug, Regression)

Details

Attachments

(1 file)

Bug 1489669 introduced an issue in GeckoViewStorageController.jsm:

Use of unknown property Ci.nsIClearDataService.CLEAR_PUSH_NOTIFICATIONS

https://searchfox.org/mozilla-central/rev/227f5329f75bd8b16c6b146a7414598a420260cb/mobile/android/modules/geckoview/GeckoViewStorageController.jsm#45

Looks like it should be: Ci.nsIClearDataService.CLEAR_DOM_PUSH_NOTIFICATIONS.

Bug 1489669 has been uplifted to 68, so maybe this should be as well.

It also implies the test coverage may not be sufficient (bug 1489669 comment 20 says the tests all pass, but this looks to me like when DOM_STORAGES is set, the push notifications wouldn't be cleared).

Flags: needinfo?(esawin)

Thanks for catching this!

The tests don't cover clearing push notifications because GeckoView doesn't support push notifications yet.

Assignee: nobody → esawin
Flags: needinfo?(esawin)
Pushed by esawin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f46e895eff1c
[1.0] Fix wrong nsIClearDataService constant name for clearing push notifications. r=Standard8
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Eugen, do we need to uplift this fix to GV 68 Beta for Fenix? Or is this "unknown property" error mostly harmless and can ride the trains in GV 69?

Flags: needinfo?(esawin)

It can ride trains, we don't support push notifications yet.

Flags: needinfo?(esawin)
You need to log in before you can comment on or make changes to this bug.