Closed Bug 1559131 Opened 2 years ago Closed 2 years ago

Perma xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_recommendations.js when Gecko 69 merges to Beta on 19-07-01

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 + fixed
firefox69 + fixed

People

(Reporter: noemi_erli, Assigned: robwu)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

Central-as-beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=51411b8325f4fcd586f946f49ba860e0d7f87113&selectedJob=251635941

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=251635751&repo=try&lineNumber=2752

[task 2019-06-13T13:02:22.824Z] 13:02:22 INFO - TEST-START | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_recommendations.js
[task 2019-06-13T13:02:25.101Z] 13:02:25 WARNING - TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_recommendations.js | xpcshell return code: 0
[task 2019-06-13T13:02:25.102Z] 13:02:25 INFO - TEST-INFO took 2280ms
[task 2019-06-13T13:02:25.102Z] 13:02:25 INFO - >>>>>>>
[task 2019-06-13T13:02:25.103Z] 13:02:25 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2019-06-13T13:02:25.103Z] 13:02:25 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2019-06-13T13:02:25.103Z] 13:02:25 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2019-06-13T13:02:25.104Z] 13:02:25 INFO - running event loop
[task 2019-06-13T13:02:25.104Z] 13:02:25 INFO - xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_recommendations.js | Starting setup
[task 2019-06-13T13:02:25.105Z] 13:02:25 INFO - (xpcshell/head.js) | test setup pending (2)
[task 2019-06-13T13:02:25.105Z] 13:02:25 INFO - PID 19456 | 1560430943456 addons.manager DEBUG Application has been upgraded
[task 2019-06-13T13:02:25.106Z] 13:02:25 INFO - PID 19456 | 1560430943457 addons.manager DEBUG Loaded provider scope for resource://gre/modules/addons/XPIProvider.jsm: ["XPIProvider", "XPIInternal"]
[task 2019-06-13T13:02:25.106Z] 13:02:25 INFO - PID 19456 | 1560430943476 addons.manager DEBUG Loaded provider scope for resource://gre/modules/addons/GMPProvider.jsm
[task 2019-06-13T13:02:25.107Z] 13:02:25 INFO - PID 19456 | 1560430943485 addons.manager DEBUG Loaded provider scope for resource://gre/modules/addons/PluginProvider.jsm
[task 2019-06-13T13:02:25.108Z] 13:02:25 INFO - PID 19456 | 1560430943487 addons.manager DEBUG Starting provider: XPIProvider
[task 2019-06-13T13:02:25.109Z] 13:02:25 INFO - PID 19456 | 1560430943488 addons.xpi DEBUG startup
[task 2019-06-13T13:02:25.111Z] 13:02:25 INFO - PID 19456 | 1560430943489 addons.xpi WARN List of valid built-in add-ons could not be parsed.: [Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)" location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: startup :: line 2243" data: no] Stack trace: startup()@resource://gre/modules/addons/XPIProvider.jsm:2243
[task 2019-06-13T13:02:25.112Z] 13:02:25 INFO - PID 19456 | callProvider()@resource://gre/modules/AddonManager.jsm:193
[task 2019-06-13T13:02:25.112Z] 13:02:25 INFO - PID 19456 | _startProvider()@resource://gre/modules/AddonManager.jsm:569
[task 2019-06-13T13:02:25.113Z] 13:02:25 INFO - PID 19456 | startup()@resource://gre/modules/AddonManager.jsm:725
[task 2019-06-13T13:02:25.114Z] 13:02:25 INFO - PID 19456 | startup()@resource://gre/modules/AddonManager.jsm:2797
[task 2019-06-13T13:02:25.114Z] 13:02:25 INFO - PID 19456 | observe()@resource://gre/modules/addonManager.js:71
[task 2019-06-13T13:02:25.114Z] 13:02:25 INFO - PID 19456 | promiseStartupManager()@resource://testing-common/AddonTestUtils.jsm:822
[task 2019-06-13T13:02:25.115Z] 13:02:25 INFO - PID 19456 | startAddonManager()@resource://testing-common/ExtensionXPCShellUtils.jsm:800
[task 2019-06-13T13:02:25.116Z] 13:02:25 INFO - PID 19456 | setup()@/builds/worker/workspace/build/tests/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_recommendations.js:37
[task 2019-06-13T13:02:25.116Z] 13:02:25 INFO - PID 19456 | run_next_test/_run_next_test/<()@/builds/worker/workspace/build/tests/xpcshell/head.js:1437
[task 2019-06-13T13:02:25.117Z] 13:02:25 INFO - PID 19456 | _run_next_test()@/builds/worker/workspace/build/tests/xpcshell/head.js:1437
[task 2019-06-13T13:02:25.117Z] 13:02:25 INFO - PID 19456 | run()@/builds/worker/workspace/build/tests/xpcshell/head.js:688
[task 2019-06-13T13:02:25.118Z] 13:02:25 INFO - PID 19456 | _do_main()@/builds/worker/workspace/build/tests/xpcshell/head.js:227
[task 2019-06-13T13:02:25.119Z] 13:02:25 INFO - PID 19456 | _execute_test()@/builds/worker/workspace/build/tests/xpcshell/head.js:529
[task 2019-06-13T13:02:25.119Z] 13:02:25 INFO - PID 19456 | -e:1

[Tracking Requested - why for this release]: flagging for 68 because addon recommendation stuff is pending uplift.

This is caused by https://hg.mozilla.org/try/rev/51411b8325f4fcd586f946f49ba860e0d7f87113#l12.15

The relevant part of the log is:

[task 2019-06-13T13:02:25.318Z] 13:02:25 INFO - xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_recommendations.js | Starting test_unsigned
[task 2019-06-13T13:02:25.319Z] 13:02:25 INFO - (xpcshell/head.js) | test test_unsigned pending (2)
[task 2019-06-13T13:02:25.319Z] 13:02:25 INFO - (xpcshell/head.js) | test run_next_test 4 finished (2)
[task 2019-06-13T13:02:25.320Z] 13:02:25 INFO - PID 19456 | 1560430944730 addons.xpi-utils WARN Add-on unsigned@test.web.extension is not correctly signed.
[task 2019-06-13T13:02:25.321Z] 13:02:25 INFO - PID 19456 | 1560430944730 addons.xpi-utils WARN Add-on unsigned@test.web.extension is not correctly signed.
[task 2019-06-13T13:02:25.322Z] 13:02:25 INFO - PID 19456 | 1560430944731 addons.xpi WARN Invalid XPI: signature is required but missing
[task 2019-06-13T13:02:25.322Z] 13:02:25 INFO - Unexpected exception Error: Expected file to be downloaded for install of /tmp/xpc-profile-NrkCvg/temp/generated-extension-3.xpi at resource://testing-common/AddonTestUtils.jsm:1327
[task 2019-06-13T13:02:25.322Z] 13:02:25 INFO - promiseInstallFile@resource://testing-common/AddonTestUtils.jsm:1327:13
[task 2019-06-13T13:02:25.323Z] 13:02:25 INFO - _do_main@/builds/worker/workspace/build/tests/xpcshell/head.js:227:6
[task 2019-06-13T13:02:25.324Z] 13:02:25 INFO - _execute_test@/builds/worker/workspace/build/tests/xpcshell/head.js:529:5
[task 2019-06-13T13:02:25.325Z] 13:02:25 INFO - @-e:1:1
[task 2019-06-13T13:02:25.326Z] 13:02:25 INFO - exiting test

Assignee: nobody → rob
Status: NEW → ASSIGNED
Flags: needinfo?(mstriemer)

test_recommendations.js has one test that verifies that an unsigned
add-on is not recommended. In order to load an unsigned add-on, it
needs to disable signing. Signing can however not be disabled when
MOZ_REQUIRE_SIGNING=1. So skip the test if require_signing is set.

Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/ffa978d11ec1
Add skip-if=require_signing to test_recommendations.js r=rpl
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Whiteboard: [checkin-needed-beta]

I believe this requires first https://bugzilla.mozilla.org/show_bug.cgi?id=1540253#c8

mozilla@ubuntu ~/mozilla-unified beta(+8) $ hg graft -er ffa978d11ec1
grafting 546126:ffa978d11ec1 "Bug 1559131 - Add skip-if=require_signing to test_recommendations.js r=rpl"
merging toolkit/mozapps/extensions/test/xpcshell/xpcshell.ini
warning: conflicts while merging toolkit/mozapps/extensions/test/xpcshell/xpcshell.ini! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')

The test doesn't exist in mozilla-beta that's why the conflict of disabling it.

Flags: needinfo?(ryanvm)

The uplift request (and desired order) is covered in this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1539699#c11 (and previous comments)

Comment on attachment 9071909 [details]
Bug 1559131 - Add skip-if=require_signing to test_recommendations.js

Beta/Release Uplift Approval Request

  • User impact if declined: Test failure when the patch to bug 1540253 is uplifted to beta.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1540253
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch disables one test when add-on signatures are mandatory, i.e. on Beta. In Fx DevEd the signature is not required, so the test continues to run and provides the desired test coverage for 68.
  • String changes made/needed: none
Attachment #9071909 - Flags: approval-mozilla-beta?

Removing checkin needed based on Comment 7 and Comment 8.

Whiteboard: [checkin-needed-beta]
Flags: needinfo?(ryanvm)
Attachment #9071909 - Flags: approval-mozilla-beta?
Whiteboard: [checkin-needed-beta]

From my understanding this issue is related to the automated tests. Is there any need of manual QA here? If not can you please mark it as "qe-verify- "

Flags: needinfo?(rob)
Flags: needinfo?(rob) → qe-verify-
You need to log in before you can comment on or make changes to this bug.