URL: Filenames with #-marks are broken

VERIFIED INVALID

Status

()

Core
Networking
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Gerrit Hannaert, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Granted, it's slightly brain-dead to use filenames containing #-marks in the URL
scheme of things. However, we have some and accessing them through the browser
does not work.

(At least Windows and Linux have no problems working with files containing the
hash mark)

example: <img src="A2_##_##.jpg">

(Oddly, <img src="A2_&#035;&#035;_&#035;&#035;.jpg"> doesn't work either)
->Networking, probably invalid.

You're escaping the #-signs the wrong way :) Try URL-encoding them (%-hex, see 
RFC 2396) and that should work, I think; unencoded, they signal the start of the 
fragment identifier portion of the URL reference, which is throwing things off.
Assignee: harishd → new-network-bugs
Component: Parser → Networking
QA Contact: moied → benc
(Reporter)

Comment 2

16 years ago
You're right: "A2_%23%23_%23%23.jpg" is the correct way to reference it (and it
works). It seemed like a bug because IE6 didn't choke on it. IE5, incidentally,
does.
OK. Resolving INVALID, then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Updated

16 years ago
Summary: Filenames with #-marks are broken → URL: Filenames with #-marks are broken

Comment 4

16 years ago
VERIFIED/invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.