Closed Bug 1559272 Opened 2 months ago Closed 2 months ago

On Linux, date-picker pop-up isn't dark in dark theme, and month and hear headers are illegible

Categories

(Calendar :: Lightning Only, defect)

Lightning 7.0
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jik, Assigned: Paenglab)

Details

Attachments

(3 files)

Attached image light-theme.png

I am using Ubuntu Linux 19.04 with GNOME.

When I switch to a dark GNOME theme, the Lightning date-picker pop-up remains light overall, but it looks like the month and year headers in the pop-up are colored as if it is dark, which makes them virtually illegible. Please see the attached screenshots of what the pop-up looks like in a light and dark theme.

Attached image dark-theme.png
Status: NEW → UNCONFIRMED
Ever confirmed: false

This adds the systemcolors check to the lightning-item-iframe.js to use this colours in the datepicker's minimonth too.

It only check on startup of the event dialog. I think to add a observer in this dialog isn't needed as it doesn't stay open too long and needs to be dynamic for this setting.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9072361 - Flags: review?(philipp)
Attachment #9072361 - Flags: approval-calendar-beta?(philipp)
Version: Trunk → Lightning 7.1
Attachment #9072361 - Flags: review?(philipp)
Attachment #9072361 - Flags: review+
Attachment #9072361 - Flags: approval-calendar-beta?(philipp)
Attachment #9072361 - Flags: approval-calendar-beta+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4cdda25ab4a7
Apply the systemcolors attribute to the Event dialog too. r=philipp

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

This is reported against which version exactly? 7.1, TB 69? Then there wouldn't be any backport necessary.

Target Milestone: --- → 7.1

But this happens in 7.0 too.

Version: Lightning 7.1 → Lightning 7.0
You need to log in before you can comment on or make changes to this bug.