Closed Bug 1559301 Opened 2 months ago Closed 2 months ago

Straighten up C/C++ standard compiler flags

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: glandium, Assigned: glandium)

Details

Attachments

(1 file)

I noticed some weird things while looking at the code, might as well fix them.

  • info.type in ('clang-cl', 'clang', 'gcc') is always true since MSVC
    support was removed.
  • For some reason, we didn't enforce C++14 on GCC.

(In reply to Mike Hommey [:glandium] from comment #1)

  • For some reason, we didn't enforce C++14 on GCC.

To be clear, this is not a problem currently, because all supported versions of GCC default to C++14. This would become a problem when future versions of GCC default to something else.

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/79b12fe97ede
Straighten up C/C++ standard compiler flags. r=nalexander

Comment on attachment 9072093 [details]
Bug 1559301 - Straighten up C/C++ standard compiler flags.

Beta/Release Uplift Approval Request

  • User impact if declined: This would be nice to have on ESR68, for downstreams that build with GCC, because we don't know if the C++ standard default in GCC will change during the lifetime of ESR68.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Everything relevant to this patch is tested in test_toolchain_configure.py, and it's a noop in practice, as of today.
  • String changes made/needed:
Attachment #9072093 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9072093 [details]
Bug 1559301 - Straighten up C/C++ standard compiler flags.

approved for 68.0b11

Attachment #9072093 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.