Closed Bug 1559316 Opened 3 months ago Closed 3 months ago

Previously selected row's badge becomes white after selecting a new row in the a11y tree

Categories

(DevTools :: Accessibility Tools, defect)

defect
Not set

Tracking

(firefox-esr60 unaffected, firefox67 disabled, firefox68 verified, firefox69 verified)

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- disabled
firefox68 --- verified
firefox69 --- verified

People

(Reporter: tbabos, Assigned: yzen)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached video Video of the issue

Affected versions
Nightly 69.0a1 (2019-06-13) (64-bit)
Beta 68.0b10 (64-bit)

Affected platforms
Windows 10 x64
Mac OS 10.13
Ubuntu 18.04

Steps to reproduce

  • Go to twitter.com (or any other page)
  • Enable a11y
  • Perform a full page contrast audit
  • Select several rows with badges

Expected result
The badges should remain displayed as before

Actual Result
The previously selected row's badge becomes white after selecting a new row

Regression range:
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=222e9db6edde5da6401c4894ea7b9ba3376434a8&tochange=bb62c9157f04f6f2daa35d6d14e2a7252b5d2c61

Bug 1558188 - Contrast badges become white upon focus via keyboard navigation - seems to be the culprit from that pushlog.

Attachment #9072240 - Attachment is obsolete: true
Attachment #9072240 - Attachment is obsolete: false
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5101d7242413
ensure badge background does not turn white when tbody gets focus on :active. r=mtigley
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Assignee: nobody → yzenevich

Verified fixed on latest Nightly 69.0a1 (2019-06-21) with Windows 10, Mac 10.14.4 and Ubuntu 18.4
Waiting for uplift to Beta.

Status: RESOLVED → VERIFIED

Comment on attachment 9072240 [details]
Bug 1559316 - ensure badge background does not turn white when tbody gets focus on :active. r=mtigley

Beta/Release Uplift Approval Request

  • User impact if declined: When using the accessibility panel, users will see the empty/white badges in the tree for selected rows when the mouse is pressed over the accessibility tree area. This makes the badges look broken.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1559317
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This was a regression from bug 1558188, dealing with focus and styling for accessibility tree in accessibility panel. Should not be risky as it's just a CSS style to not white out the badges.
  • String changes made/needed: None
Attachment #9072240 - Flags: approval-mozilla-beta?

Comment on attachment 9072240 [details]
Bug 1559316 - ensure badge background does not turn white when tbody gets focus on :active. r=mtigley

Low-risk fix, Beta68+

Attachment #9072240 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified - Fixed on latest Beta13 on Windows 10, Windows 7, Mac OS 10.13 and Ubuntu 18.04.

You need to log in before you can comment on or make changes to this bug.