Closed Bug 1559317 Opened 4 months ago Closed 4 months ago

When a row is selected the whole a11y tree will get the focus highlight

Categories

(DevTools :: Accessibility Tools, defect)

defect
Not set

Tracking

(firefox-esr60 unaffected, firefox67 disabled, firefox68 verified, firefox69 verified)

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- disabled
firefox68 --- verified
firefox69 --- verified

People

(Reporter: tbabos, Assigned: yzen)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached video Video of the issue

Affected versions
Nightly 69.0a1 (2019-06-13) (64-bit)
Beta 68.0b10 (64-bit)

Affected platforms
Windows 10 x64
Mac OS 10.13
Ubuntu 18.04

Steps to reproduce

  • Go to twitter.com (or any other page)
  • Enable a11y
  • Use keyboard navigation to perform a full page audit
  • Select a row using TAB key
  • Click on any other row using the mouse

Expected result
The rows should be highlighted correctly without any additional focus

Actual Result
When a row is selected the whole a11y tree will get the focus highlight
Note: this is reproducible only after the user used once keyboard only navigation with TAB button

Regression range:
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=222e9db6edde5da6401c4894ea7b9ba3376434a8&tochange=bb62c9157f04f6f2daa35d6d14e2a7252b5d2c61

Bug 1558188 - Contrast badges become white upon focus via keyboard navigation - seems to be the culprit from that pushlog.

Attachment #9072241 - Attachment is obsolete: true
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4c6d64a74105
prevent on mouse down default action on TreeView's tbody so it never gets focused state. r=mtigley
Blocks: 1560238
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Flags: needinfo?(yzenevich)
Attachment #9072852 - Attachment is obsolete: true
Attachment #9072241 - Attachment is obsolete: false
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7dd587e1d948
ensure outline is not visible when tbody gets focus on :active. r=mtigley
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Verified fixed on latest Nightly 69.0a1 (2019-06-21) with Windows 10, Mac 10.14.4 and Ubuntu 18.4
Waiting for uplift to Beta.

Comment on attachment 9072241 [details]
Bug 1559317 - ensure outline is not visible when tbody gets focus on :active. r=mtigley

Beta/Release Uplift Approval Request

  • User impact if declined: When using the accessibility panel, users will see the focus outline that would be confusing as it only happens when the mouse is pressed over the accessibility tree area.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1559316
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This was a regression from bug 1558188, dealing with focus and styling for accessibility tree in accessibility panel. Should not be risky as it's just a CSS style to not show the outline described by the bug.
  • String changes made/needed: None
Attachment #9072241 - Flags: approval-mozilla-beta?

Comment on attachment 9072241 [details]
Bug 1559317 - ensure outline is not visible when tbody gets focus on :active. r=mtigley

Low risk fix, verified on Nightly69, Beta68+

Attachment #9072241 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified - Fixed on latest Beta13 on Windows 10, Windows 7, Mac OS 10.13 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.