Closed Bug 1559372 Opened 2 years ago Closed 2 years ago

Find in page doesn’t work for Instagram Following

Categories

(Core :: Find Backend, defect, P2)

67 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1482147
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix

People

(Reporter: aruseni.magiku, Unassigned)

References

(Regression)

Details

(Keywords: regression, reproducible)

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

  1. Opened Instagram
  2. Opened the “Following” list (see screenshots)
  3. Tried to find a user using Ctrl + F

Actual results:

I can find the user if they are either displayed or if you scroll further down. If they are below the displayed portion of the scrollable list, they are not found.

Expected results:

I expect any (loaded) text to be found with Ctrl + F. I checked that the element is present in the DOM: you can find the li element for this user if you search for it with the Developer Tools.

Attached image found.png
Attached image not_found.png
Component: Untriaged → Find Toolbar
Keywords: reproducible
Product: Firefox → Toolkit
Status: UNCONFIRMED → NEW
Ever confirmed: true

This is a regression since Firefox61.0.

Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8994f35fe5fc89f4e8f4e09579a6962f8a4a3e65&tochange=ef1db4e8bf066e5fcf80a0cd85835fada3a1dbbd

Regressed by: Bug 1436431

Brad Werth,
Your bunch of patch seems to cause the regression. Can you please look into this?

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(bwerth)
Regressed by: 1436431
Attached file reduced html

Too late for a fix in 68 but we could still potentially take a patch for 69/70.
Mike, can you assign a priority to this issue? Thanks!

Flags: needinfo?(mdeboer)

Brad, is this perhaps a known issue already that we can dupe, perhaps?

Component: Find Toolbar → Find Backend
Flags: needinfo?(mdeboer)
Priority: -- → P2
Product: Toolkit → Core

(In reply to Mike de Boer [:mikedeboer] from comment #7)

Brad, is this perhaps a known issue already that we can dupe, perhaps?

Very possibly this is Bug 1482147. I'm going to make this blocked by that bug for now, and will re-test when that bug lands to see if this one is a duplicate.

Depends on: 1482147
Flags: needinfo?(bwerth)

I actually can't reproduce in Instagram, but the description of the problem matches what is going on in Bug 1482147.

(In reply to Brad Werth [:bradwerth] from comment #9)

I actually can't reproduce in Instagram, but the description of the problem matches what is going on in Bug 1482147.

I can reproduce. The key is to get the searched-for-text to be within the bounds of the window, but out of view of the scrollable element. This is trivial on Instagram if you bring up the following pop-up, scroll down a bit and note the text there, scroll back up and then search for the target text. It will not be found.

This is further evidence that this is Bug 1482147. I'm marking this bug as a duplicate.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1482147
You need to log in before you can comment on or make changes to this bug.