Closed Bug 1559375 Opened 1 year ago Closed 1 year ago

Allow qualified AMD devices to get WR in late beta and release

Categories

(Core :: Graphics: WebRender, task, P2)

68 Branch
Unspecified
Windows 10
task

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- verified
firefox69 --- verified

People

(Reporter: peter.magyari, Assigned: kats)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

[Note]

This issue does not occur on machines with Nvidia graphics cards

[Affected versions]

Firefox Beta 68.0b9
Firefox Beta 68.0b10

[Affected platforms]

Windows 10

[Steps to reproduce]

  1. Open browser.
  2. Go to about:support and check if under Graphics -> Compositing = Webrender
    If it is not activated by default, go to about:config and add the following boolean: "gfx.webrender.all.qualified = true" in order to enable it
  3. Restart the browser

[Expected result]

WebRender should be enabled.

Actual result

WebRender is not enabled.

[Additional notes]

This issue does not occur on Firefox Nightly 69.0a1.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
See Also: → 1548121

I think the plan is to actually let WR for AMD to ride to release in 68, so we should drop that ifdef.

Assignee: nobody → kats
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment on attachment 9072165 [details]
Bug 1559375 - Allow qualified AMD devices to get WR in late beta and release. r?jrmuizel

Beta/Release Uplift Approval Request

  • User impact if declined: Windows users with modern AMD graphics cards won't get WR enabled in 68
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Once patch is uplifted and is in a beta build, ensure Firefox running on a modern AMD graphics card has WebRender enabled by default
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just dropping an ifndef. It was an oversight that we left this in - AMD users were getting WR enabled upto and including 68.0b8 so in terms of beta testing we only lost a couple of beta builds (b9 and b10) worth of bake time.
  • String changes made/needed:
Attachment #9072165 - Flags: approval-mozilla-beta?
Blocks: wr-68
Type: defect → task
Priority: -- → P2
Summary: WebRender cannot be activated on Beta builds using config on machines with AMD graphics cards (only forced) → Allow qualified AMD devices to get WR in late beta and release
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c97ee92e2290
Allow qualified AMD devices to get WR in late beta and release. r=jrmuizel
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9072165 [details]
Bug 1559375 - Allow qualified AMD devices to get WR in late beta and release. r?jrmuizel

ship WR for some AMD devices, approved for 68.0b11

Attachment #9072165 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

While importing this patch to uplift it for beta I ran into a conflict because the patch was based off central or at least that is my guess.

Could you please take a look?

Flags: needinfo?(kats)

Verified fixed on Firefox Beta 68.0b11 (20190617172838) and Firefox Nightly 69.0a1 (20190617214029)
WebRender is enabled by default

You need to log in before you can comment on or make changes to this bug.