Closed Bug 1559478 Opened 2 years ago Closed 6 months ago

Expose chrome-only `browsingContext` attribute on remote & non-remote `WindowProxy` objects.

Categories

(Core :: DOM: Core & HTML, task, P2)

task

Tracking

()

RESOLVED DUPLICATE of bug 1638153
Fission Milestone M6

People

(Reporter: nika, Assigned: kashav)

References

(Blocks 1 open bug)

Details

It might be really nice to expose this information on remote/non-remote WindowProxy objects. It would let chrome JS code get the BrowsingContext off of a WindowProxy reliably, whether or not it is in the current process.

Figured I'd file this and ni? :mccr8 to see how practical this would be to make happen.

Flags: needinfo?(continuation)

I don't know. I'm not sure why you think I might know. :) What sort of problems do you anticipate?

Flags: needinfo?(continuation)
Assignee: nobody → continuation
Status: NEW → ASSIGNED
Priority: -- → P2
Blocks: fission
Type: enhancement → task
See Also: → 1532795
Blocks: fission-mochitests
No longer blocks: fission
Assignee: continuation → nobody
Status: ASSIGNED → NEW
Assignee: nobody → kmadan
Status: NEW → ASSIGNED

Roll some unfixed bugs from Fission Milestone M4 to M5

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: M4 → M5

M6

Blocks: fission
No longer blocks: fission-mochitests
Fission Milestone: M5 → M6
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1638153
You need to log in before you can comment on or make changes to this bug.