Closed Bug 1559518 Opened 6 months ago Closed 6 months ago

Twitter rendered incorrectly if zoom < 100%

Categories

(Core :: Graphics, defect, P1)

69 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- unaffected
firefox69 + verified

People

(Reporter: euthanasia_waltz, Assigned: rhunt)

References

(Regression)

Details

(Keywords: regression, reproducible)

Attachments

(4 files)

(Build ID: 20190614100022)

STR:

  1. Go to twitter(https://twitter.com/FirefoxNightly e.g.)
  2. Set zoom to 90%
  3. click large image in tweet (to see the issue easily)

AR:

  1. No close button
  2. Partialy rendered(or missing) reply/retweet/favorite buttons/counts
  3. Incorrect(much smaller) background shade of a tweet(not matched with client window), sometimes
  4. and so on(?)(scrollbar vanished, sticked header short width, e.g. but I cannot say all these problems are concerned with this bug)

mozregression:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a91efd693851d156f5680c88e6f91d12406ec3fe&tochange=94b369f38c536a4cc3b308311b1e88825e581ff5

Regressed by: 1558482
Attached image bad example
Attached image normal(zoom=100%) image
Attachment #9072288 - Attachment description: normal(zoom → normal(zoom=100%) image

I can also reproduce the issue on Nightly69.0a1 Windows10.
(Unfortunately, Bug 1559211 does not fix this.)

Ryan Hunt,
Can you please look into this?

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(rhunt)

Another STR

  1. Open any Video page (incl. standalone/local video)
    ( e.g https://base-n.de/webm/VP9%20Sample.html )
  2. Zoom out
  3. Click on fullscreen icon at the end of video controls

Actual Results:
Right and bottom parts(incl. video controls) of video is truncated.

Duplicate of this bug: 1559557

This change was suspect to not work under full page zoom, but I thought it
would be okay as it would only affect OOP-iframes. That was not true.

Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/autoland/rev/e593e11eff08
Revert composition size changes as they also affect top level remote browsers. r=kats
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

(In reply to Ryan Hunt [:rhunt] from comment #6)

Created attachment 9072532 [details]
Bug 1559518 - Revert composition size changes as they also affect top level
remote browsers. r?kats

This change was suspect to not work under full page zoom, but I thought it
would be okay as it would only affect OOP-iframes. That was not true.

(In reply to Pulsebot from comment #7)

Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/autoland/rev/e593e11eff08
Revert composition size changes as they also affect top level remote
browsers. r=kats

This did not fix anything on latest autoland build.
I can still reproduce the issue of comment#0, comment#4 and Bug 1559557.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla69 → ---
Priority: -- → P1
Assignee: nobody → rhunt

App units of a remote browser element in the parent process are
different from app units inside the remote content in the child
process. We should apply the appropriate conversions by exposing
the relevant data as LayoutDevicePixel.

See Also: → 1560082
Flags: needinfo?(rhunt)
Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/autoland/rev/8d7491cb1c12
Use LayoutDevicePixel for BrowserChild visible rect and composition size. r=kats
Status: REOPENED → RESOLVED
Closed: 6 months ago6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Blocks: 1560272
Regressions: 1560542
Duplicate of this bug: 1559875
Flags: qe-verify+

Issue confirmed with (Build ID: 20190614100022) on Windows 10.
Fix verified with 69.0b7 on Windows 10, macOS 10.13, Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.