Some images vibrate/ jiggle / oscillate back and forth

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
2 months ago

People

(Reporter: twm, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Linux
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Version: 2002070508, x86 Linux (KDE)
Repeatable: Every time!
The above url (www.untitledgif.org/archive.html) has two images on it that
vibrate back and forth when I view the page. They are the images of "Bob
Stubaggio" (bob.gif) and "Genocide Cannon" (cannon.gif). This is really strange.
The images aren't animated and there's nothing funny going on in the html.
Several previous versions of Mozilla didn't vibrate these guys, either.
WFM, build 2002070310 winXP

Comment 2

17 years ago
wfm, linux build 20020704
do the images vibrate if you right click and "view image", or only within the
html page?
(Reporter)

Comment 3

17 years ago
No, they don't vibrate on their own, only within the html.
I am seeing the vibrating images also. And they are fine when using the
view-image menu item.
It is ok for me now (linux 2002102908). Tom, do you still see this?
(Reporter)

Comment 6

16 years ago
Still happens in 2002100604 on linux; I'll try out a new nightly soon...

(Though to tell you the truth, I would sort of miss this bug...!)

Comment 7

16 years ago
I can reproduce this on solaris 8/sparc using nightly 2002110322. Bob and the
cannon oscillate about 4x/second, generally up and down but sometimes
side-to-side. I have some random observations:

1) With the web page, if I scroll the page so that part of bob or the cannon is
off the top of the content area, that image stops oscillating. They keep
shimmering though if I scroll them partway off the bottom of the viewing image.

2) View->Page Info->Media and select the bob gif or the cannon gif. The images
shimmer in the preview area too, but only if the preview area is smaller than a
certain size vertically. Try resizing the page info area until a vertical
scrollbar appears in the image preview area.

3) The effect is completely repeatable. I can resize the browser window, load
other pages, etc., but ol' Bob keeps dancing.

I'll attach a reduced version of the web page. If I remove the center tags or h1
tags the effect is destroyed. Changing h1 to h2, or moving the h1 section
outside the center tags, also destroys the effect. Moving the IMG tag outside
the center tags does NOT destroy the effect.

Comment 8

16 years ago
Created attachment 105144 [details]
Reduced version of the web page

Comment 9

16 years ago
Created attachment 105146 [details]
Process traces and stack dumps (zipped)

This zip archive contains ten traces of mozilla with corresponding stack dumps.
Mozilla was idle, other than animating one of the images (the cannon gif; bob
was offscreen).

I used "truss -l -u '!libthread,libc,libc_psr' -u '*' -T write" to trace
mozilla. This causes truss to trace library calls (excluding libthread and
libc) as well as system calls; it halts the process every time a write() is
performed. The stack traces were taken each time truss halted the process.

About every third process trace ends in a write() of about 5k to FD 6. As far
as I could tell, these were the writes that caused the image to move.

Comment 10

16 years ago
ok, I'm seeing this with the URL and Kenneth's testcase.  It seems to be
somewhat profile-specific as well.  A pristine profile exhibits the bug.

regression between linux trunk builds 2002061108 and 2002061304
marking NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, testcase

Updated

12 years ago
Assignee: pavlov → nobody
QA Contact: tpreston → layout.images

Comment 11

3 years ago
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID 	20160323030400

Closing this as WFM because I can't reproduce on the current Firefox release (v. 45) nor on Nightly 48.0a1. 
Being an old issue, it might be fixed in the meantime. However if anyone can still reproduce this on a current build, fell free to reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

2 months ago
Product: Core → Core Graveyard

Updated

2 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.