Closed Bug 1559689 Opened 7 months ago Closed 7 months ago

Allow history highlights that happen to be bookmarked to appear in normal chronological history order

Categories

(Firefox :: New Tab Page, enhancement, P1)

68 Branch
Desktop
All
enhancement

Tracking

()

VERIFIED FIXED
Firefox 69
Iteration:
69.4 - Jun 24 - Jul 7
Tracking Status
firefox69 --- verified

People

(Reporter: simon+mozilla, Assigned: Mardak)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(1 file)

Even tough I have bookmarks disabled for the new-tab highlights section, they still end up as the first entries for a long time after visiting. Before downloads and normal history.

Expected: with the bookmarks option unset, treat visited bookmarks the same as normal history visits.

Are you seeing the highlight cards with the bookmark blue star or that you're noticing the history cards happen to be pages that you've bookmarked? Highlights doesn't show every page from history and only those that have enough page metadata (e.g., image), but it does show them based on how recently you've been to the page.

Flags: needinfo?(simon+mozilla)

They are not shown with blue stars but always in this order: visits to bookmarks > downloads > normal history visits.
Right now it is sorting visits to bookmarked sites from 09:30 before the remainder of my history of the day up to 22:50, but indicating both with the clock symbol.
Even if not revisited, those bookmark visits will persist in first place for several days, at least.

I assumed it's supposed to separate enabled sections from each other and sort them individually, since this is what happens on my end.

Flags: needinfo?(simon+mozilla)

The behavior was set in bug 1451091 and implemented to specially treat bookmarked history pages:

https://searchfox.org/mozilla-central/rev/7e158713cf5a8514fa8161dd4a239737b05da64d/browser/components/newtab/lib/HighlightsFeed.jsm#106-108

The spec doesn't seem to mention any special behavior for bookmarked history -- just recent bookmarks:

https://mozilla.invisionapp.com/share/C4GL6VF2KRY#/screens

I would guess the special logic was so that highlight cards always showed starred cards before history, but maybe that's not the desired behavior anymore.

wolasi, is it okay if highlights shows [history] [bookmark] [history] instead of [bookmark] [history] [history] if a page that happened to be bookmarked was visited recently? A recently created bookmark (or pocketed story or download) would still always appear before history.

Type: defect → enhancement
Depends on: 1451091
Flags: needinfo?(wkonu)
Summary: Highlights: disabled bookmarks, still shown in first place → Allow history highlights that happen to be bookmarked to appear in normal chronological history order

I don't follow your example Ed.

That said, based on the issue described, if a user has disabled a highlight type (bookmark, history, download etc), and a highlight item has two type properties e.g. bookmarked and recently visited, the highlight item should be sorted only on the type that the user has opted to see, so in this case the date it was last visited.

Flags: needinfo?(wkonu)
Assignee: nobody → edilee
Iteration: --- → 69.4 - Jun 24 - Jul 7
Priority: -- → P1
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Blocks: 1561811
Keywords: github-merged
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Component: Activity Streams: Newtab → New Tab Page

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (69.0a1 Build ID - 20190701215217) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, if the bookmarks are disabled for the highlights section the bookmarked card is no longer displayed even if is visited.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.