Closed Bug 1559718 Opened 4 months ago Closed 3 months ago

Unable to login in monitor.firefox.com after changing password

Categories

(Firefox :: Firefox Monitor, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: firefox, Unassigned)

Details

Like here : https://support.mozilla.org/en-US/questions/1261389
and here : https://support.mozilla.org/en-US/questions/1261230
I'm unable to login in my monitor.firefox.com account after changing my accounts.firefox.com password.
It work for oauth in send.firefox.com
Add-on or not, it fail to login.

I don't know how to reproduce : i've test to create a new account, then changing password, it still working... but not in my main account.

I've test to change again my main account password, it don't work better.
I had one time this :

Invalid state: 5a10553f16b81fef04f1d354b3ace9b020467ebbef2e1cfeee481c63a0f274a86f3d283fa071561b

instead of this :
You must be signed in to your Firefox Account.

But no successfull login.

The priority flag is not set for this bug.
:nhnt11, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(nhnt11)

Luke, Lesley, could one of you please link this to a GitHub issue? I'll close this once that's done.

Flags: needinfo?(nhnt11)
Flags: needinfo?(lnorton)
Flags: needinfo?(lcrouch)

I can't reproduce this bug.

:bobm - any chance there's some IP-based blocking interference going on here?

Flags: needinfo?(lcrouch) → needinfo?(bobm)

This is a problem with our accounts. I've tried many different places/devices:
https://i.imgur.com/FbvPAUh.png

Idk if this may have something to do with it, but I listed an email address for monitoring that I couldn't verify (I no longer have access).

(In reply to Luke Crouch [:groovecoder] from comment #3)

:bobm - any chance there's some IP-based blocking interference going on here?

The IP blocking would block all access, so I don't think that's in play here.

Flags: needinfo?(bobm)

(In reply to Luke Crouch [:groovecoder] from comment #3)

I can't reproduce this bug.

I don't know how to reproduce the initial part of the bug, but using my firefox account, i can reproduce the login error bug any time.

If i can export my private data to import them in an other account, after some cleaning, i can share my account to explore this bug.

If you want to explore this, just say it.

I have this same problem. I found this bug report from the FireFox Monitor support page. I have two laptops running Windows 10 with Firefox default browser. One of them allows me to log into Firefox Monitor and the other gives me this same login error whenever I try to access the page.

Also being hit. I could change my password, use Firefox Monitor for some time, like one or two hours. And now, completely blocked.

FTR, tried private browsing, logging in from multiple devices. Firefox Accounts OAuth flow is fine. Firefox Monitor sessions are reported active in Firefox Accounts "Clients" list.

(In reply to Alexandre LISSY :gerard-majax from comment #8)

Also being hit. I could change my password, use Firefox Monitor for some time, like one or two hours. And now, completely blocked.

Also I forgot to mention this happened without me disconnecting, and not even restarting Nightly.

If it helps, network monitor in devtools shows:
200 POST accounts.firefox.com/metrics
302 GET monitor.firefox.com/confirmed?code=...&state=...&action=signin
500 GET monitor.firefox.com/dashboard

Flags: needinfo?(lcrouch)

(In reply to Nihanth Subramanya [:nhnt11] (catching up from vacation backlog) from comment #2)

Luke, Lesley, could one of you please link this to a GitHub issue? I'll close this once that's done.

Looks like someone opened it there as well https://github.com/mozilla/blurts-server/issues/1146

GitHub is the right place for this specific bug, as this component is for things within the Firefox UI.

Those interested should follow https://github.com/mozilla/blurts-server/issues/1146.

Flags: needinfo?(lnorton)
Flags: needinfo?(lcrouch)

(Don't anyone panic: INVALID in this case just refers to where it is in our system. The bug is valid and actionable on GitHub.)

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → INVALID

Idk what you guys did, but it started working now.

(In reply to laurileet from comment #15)

Idk what you guys did, but it started working now.

Same for me. It now work back ! Thanks !

'Unexpected error' today. But I already see Sentry caught it, so you should be aware.

You need to log in before you can comment on or make changes to this bug.