Perma PID 4053 | FATAL ERROR: Non-local network connections are disabled and a connection attempt to 127.0.0.1.woopra-ns.com (173.239.5.6) was made.

RESOLVED FIXED in Firefox 69

Status

defect
P1
normal
RESOLVED FIXED
Last month
23 days ago

People

(Reporter: intermittent-bug-filer, Assigned: Bebe)

Tracking

({regression})

Version 3
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 fixed)

Details

Attachments

(1 attachment)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=252148497&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/QOjbldBKQN--sYCLFRTUbg/runs/0/artifacts/public/logs/live_backing.log


06:28:12 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" "httpdisabled://space.56.com/php/urs.php" ({})
06:28:12 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" null ({})
06:28:12 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" "httpdisabled://space.56.com/php/urs.php" ({})
06:28:12 INFO - PID 4053 | console.warn: nsLoginManager: "searchLogins: formActionOrigin or httpRealm is recommended"
06:28:12 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" null ({})
06:28:12 INFO - PID 4053 | console.warn: nsLoginManager: "searchLogins: formActionOrigin or httpRealm is recommended"
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" "httpdisabled://jsso.indiatimes.com/sso/IndiatimesEmailLogin?ru=http://mb.indiatimes.com/public/login.jsp&nru=http://mb.indiatimes.com/public/login_redo.jsp&siteid=ebdccde5269865f726086aac8047fc06" ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" null ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" "httpdisabled://jsso.itimes.com/sso/ITimesLogin?ru=http://www.itimes.com/dologin.php&siteid=bb857c2ade1c6bcc4a9cccc12e89e39b&nru=http://www.itimes.com" ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" null ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" "httpdisabled://www.mocolife.com/itlogin.aspx?itp=1" ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" null ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" "httpdisabled://jsso.indiatimes.com/sso/IndiatimesEmailLogin?ru=http://mb.indiatimes.com/public/login.jsp&nru=http://mb.indiatimes.com/public/login_redo.jsp&siteid=ebdccde5269865f726086aac8047fc06" ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" null ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" "httpdisabled://jsso.itimes.com/sso/ITimesLogin?ru=http://www.itimes.com/dologin.php&siteid=bb857c2ade1c6bcc4a9cccc12e89e39b&nru=http://www.itimes.com" ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" null ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" "httpdisabled://www.mocolife.com/itlogin.aspx?itp=1" ({})
06:28:14 INFO - PID 4053 | console.warn: LoginHelper: "Couldn't parse origin for" null ({})
06:28:14 INFO - PID 4053 | console.warn: nsLoginManager: "searchLogins: formActionOrigin or httpRealm is recommended"
06:28:14 INFO - PID 4053 | console.warn: nsLoginManager: "searchLogins: formActionOrigin or httpRealm is recommended"
06:28:14 INFO - PID 4053 | console.warn: nsLoginManager: "searchLogins: formActionOrigin or httpRealm is recommended"
06:28:14 INFO - PID 4053 | console.warn: nsLoginManager: "searchLogins: formActionOrigin or httpRealm is recommended"
06:28:14 INFO - PID 4053 | console.warn: nsLoginManager: "searchLogins: formActionOrigin or httpRealm is recommended"
06:28:14 INFO - PID 4053 | console.warn: nsLoginManager: "searchLogins: formActionOrigin or httpRealm is recommended"
06:28:16 INFO - PID 4053 | FATAL ERROR: Non-local network connections are disabled and a connection attempt to 127.0.0.1.woopra-ns.com (173.239.5.6) was made.
06:28:16 INFO - PID 4053 | You should only access hostnames available via the test networking proxy (if running mochitests) or from a test-specific httpd.js server (if running xpcshell tests). Browser services should be disabled or redirected to a local server.
06:28:16 INFO - PID 4053 | ExceptionHandler::GenerateDump cloned child 8866
06:28:16 INFO - PID 4053 | ExceptionHandler::SendContinueSignalToChild sent continue signal to child
06:28:16 INFO - PID 4053 | ExceptionHandler::WaitForContinueSignal waiting for continue signal...
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | Exiting due to channel error.
06:28:16 INFO - PID 4053 | [GPU 4088, Chrome_ChildThread] WARNING: pipe error (25): Connection reset by peer: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 358
06:28:16 INFO - Terminating psutil.Process(pid=4053, name='firefox-bin', started='06:27:52')
06:28:16 INFO - TEST-INFO | 4053: exit 11
06:28:16 INFO - TEST-UNEXPECTED-ERROR | tabswitch | Could not find report in browser output: [('tsformat', ('__start_report', '__end_report')), ('tpformat', ('__start_tp_report', '__end_tp_report'))]
06:28:16 ERROR - Traceback (most recent call last):

See Also: → 1554570

Florin, could you please take a look at this bug, it's permafailing on tabswitch jobs across all platforms and it looks similar to Bug 1554570. https://tinyurl.com/y6hdfxk2
This is about connecting to 127.0.0.1.woopra-ns.com and not ping.ie.sogou.com. Thank you.

10:48:05 INFO - PID 4579 | console.warn: nsLoginManager: "searchLogins: formActionOrigin or httpRealm is recommended"
10:48:07 INFO - PID 4579 | FATAL ERROR: Non-local network connections are disabled and a connection attempt to 127.0.0.1.woopra-ns.com (173.239.5.6) was made.
10:48:07 INFO - PID 4579 | You should only access hostnames available via the test networking proxy (if running mochitests) or from a test-specific httpd.js server (if running xpcshell tests). Browser services should be disabled or redirected to a local server.
10:48:07 INFO - PID 4579 | ExceptionHandler::GenerateDump cloned child 9369
10:48:07 INFO - PID 4579 | ExceptionHandler::SendContinueSignalToChild sent continue signal to child
10:48:07 INFO - PID 4579 | ExceptionHandler::WaitForContinueSignal waiting for continue signal...
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - PID 4579 | Exiting due to channel error.
10:48:07 INFO - Terminating psutil.Process(pid=4579, name='firefox-bin', started='10:47:44')
10:48:07 INFO - TEST-INFO | 4579: exit 11
10:48:07 INFO - TEST-UNEXPECTED-ERROR | tabswitch | Could not find report in browser output: [('tsformat', ('__start_report', '__end_report')), ('tpformat', ('__start_tp_report', '__end_tp_report'))]

Flags: needinfo?(fstrugariu)
Assignee: nobody → fstrugariu
Depends on: 1559889
Priority: P5 → P1

try build with the fix
https://treeherder.mozilla.org/#/jobs?repo=try&revision=25705b7775b942c8878601802ffaa37450f0be2e

I replaced http/https with httpdissabled/httpsdissabled

This will prevent any outbound connections

Flags: needinfo?(fstrugariu)

The jobs on try are green. The patch still needs to be r+ by someone.

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/24771a8702c2
Non-local network connections are disabled and a connection attempt to 127.0.0.1.woopra-ns.com r=jmaher
Status: NEW → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Duplicate of this bug: 1560564
You need to log in before you can comment on or make changes to this bug.