Closed Bug 1559773 Opened 6 months ago Closed 2 months ago

geckodriver returns too early from trying to connect to Marionette

Categories

(Testing :: geckodriver, defect, P3)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1575021

People

(Reporter: whimboo, Unassigned)

References

(Depends on 1 open bug)

Details

Sometimes geckodriver returns too early from trying to connect to Marionette:

11:09:12 INFO - PID 748 | 1560596952859 geckodriver::marionette DEBUG Waiting 60s to connect to browser on 127.0.0.1:2828
11:09:13 INFO - PID 748 | [10404, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/extensions/permissions/nsPermissionManager.cpp, line 2903
11:09:13 INFO - PID 748 | 1560596953963 mozrunner::runner DEBUG Killing process 6912

As you can see this happens within a single second! There is an internal issue but I don't see that this caused something bad like a crash. But maybe that is possible, and due to bug 1490906 we don't see that here.

https://phabricator.services.mozilla.com/D44896 might help here.
It changes geckodriver to wait for the Marionette handshake instead
of the initial connection.

Depends on: 1525126
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1575021
You need to log in before you can comment on or make changes to this bug.