Closed Bug 1559879 Opened 1 year ago Closed 8 months ago

4.66 - 9.61% sessionrestore / startup_about_home_paint / tscrollx (linux64-shippable-qr) regression on push 431c5142ff3ad102328d90cb29470b20ccd1271e

Categories

(Core :: Graphics: WebRender, defect, P3)

x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 - wontfix
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: igoldan, Assigned: gw)

References

(Blocks 1 open bug, Regression)

Details

(4 keywords)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=855d557b82a20e1ed87af46bceac3b918534d37e&tochange=431c5142ff3ad102328d90cb29470b20ccd1271e

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

10% tscrollx linux64-shippable-qr opt e10s stylo 1.75 -> 1.92
5% sessionrestore linux64-shippable-qr opt e10s stylo 985.38 -> 1,034.67
5% startup_about_home_paint linux64-shippable-qr opt e10s stylo 1,225.17 -> 1,282.25

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=21465

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling

Component: General → Graphics: WebRender
Product: Testing → Core
Flags: needinfo?(gwatson)
Priority: -- → P3

I'm not particularly concerned with these results - it's somewhat expected that the new picture caching implementation is a small-ish performance regression on some pages (particularly on a fresh load) at the moment due to the way it draws to fixed size tiles.

In the next week or so, I intend to land a patch that supports multi-resolution tiles. I'll post a link to that bug here once it's filed and we can see what result that has on these numbers. If that doesn't move the results at all, then I'll do a bit more investigation to see what else may have caused this change.

Flags: needinfo?(gwatson)
Assignee: nobody → gwatson

I don't think we need to track this for 69 since QR isn't shipping for Linux in that release AFAIK. That said, could you please add a dep for the bug where the follow-up work is happening Glenn? Thanks!

Sure, I added dependencies on this bug for the next two bugs related to this. It's possible there might be some further bugs after those land, depending on what the performance results are.

Depends on: 1561812, 1562513
Flags: needinfo?(gwatson)

Most of the picture caching improvements related to the comments above have landed now, so I took a look at current performance of these tests on m-c.


tscrollx linux64-shippable-qr opt e10s stylo
1.92 -> 1.2 (seems significantly better than before this regression)

https://treeherder.mozilla.org/perf.html#/graphs?highlightedRevisions=166f0ba2517f&series=mozilla-central%2C843918f23a1947513e832c56cc3e3074bf53af3d%2C1%2C1&series=try%2C843918f23a1947513e832c56cc3e3074bf53af3d%2C1%2C1&timerange=172800


sessionrestore linux64-shippable-qr opt e10s stylo
1034 -> 1013 (seems to be back to nearly the same performance as before this regression)

https://treeherder.mozilla.org/perf.html#/graphs?highlightedRevisions=166f0ba2517f&series=mozilla-central%2C24e203708d4ab7d8b9ecee1b57ef87d4fad3c7ff%2C1%2C1&series=try%2C24e203708d4ab7d8b9ecee1b57ef87d4fad3c7ff%2C1%2C1&timerange=172800


startup_about_home_paint linux64-shippable-qr opt
1282 -> 1235 (seems to be back to nearly the same performance as before this regression)

https://treeherder.mozilla.org/perf.html#/graphs?highlightedRevisions=166f0ba2517f&series=mozilla-central%2C046b161c6e3a8f6b67bb5017c27b1fdbd1329322%2C1%2C1&series=try%2C046b161c6e3a8f6b67bb5017c27b1fdbd1329322%2C1%2C1&timerange=172800


If I've interpreted the data correctly, I think we can resolve this as fixed now?

Flags: needinfo?(igoldan)

Indeed, the regressions look fixed. We can now close this bug.

Thanks, Glenn!

Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(igoldan)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.