Closed Bug 1559919 Opened 6 months ago Closed 5 months ago

Finish the WorkerHolder cleanup

Categories

(Core :: DOM: Workers, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: baku, Assigned: baku)

References

Details

Attachments

(11 files)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review

In this bug I'm planning to:

  1. introduce IPCWorkerRef - something in between WeakWorkerRef and StrongWorkerRef for IPC messages. IPCWorkerRef keeps the worker thread alive but it doesn't prevent the worker shutdown.
  2. Remove the remaining WorkerHolder classes
  3. Remove WorkerHolderToken
  4. Get rid of WorkerHolder completely.
Priority: -- → P1
Duplicate of this bug: 1469181
Duplicate of this bug: 1475627
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce9a22196682
Finish the WorkerHolder cleanup - part 1 - IndexedDB doesn't use WorkerHolder, r=asuth
https://hg.mozilla.org/integration/autoland/rev/d6a7b9f0cc2f
Finish the WorkerHolder cleanup - part 2 - Remove dead code in PerformanceStorageWorker, r=asuth
https://hg.mozilla.org/integration/autoland/rev/65a2c0e1eb1e
Finish the WorkerHolder cleanup - part 3 - IPCWorkerRef r=asuth
https://hg.mozilla.org/integration/autoland/rev/e1cae929e9c5
Finish the WorkerHolder cleanup - part 4 - IPCWorkerRef in ServiceWorkerContainerChild, r=asuth
https://hg.mozilla.org/integration/autoland/rev/e6ee63850e41
Finish the WorkerHolder cleanup - part 5 - IPCWorkerRef in ServiceWorkerRegistrationChild, r=asuth
https://hg.mozilla.org/integration/autoland/rev/7b84345b4725
Finish the WorkerHolder cleanup - part 6 - IPCWorkerRef in ServiceWorkerChild, r=asuth
https://hg.mozilla.org/integration/autoland/rev/5af07a1087d3
Finish the WorkerHolder cleanup - part 7 - IPCWorkerRef in ClientManagerChild, r=asuth
https://hg.mozilla.org/integration/autoland/rev/c07ebc67fee0
Finish the WorkerHolder cleanup - part 8 - Get rid of WorkerHolderToken, r=asuth
https://hg.mozilla.org/integration/autoland/rev/ca37d95ba0f7
Finish the WorkerHolder cleanup - part 9 - Notification API ported to WorkerRef, r=asuth
https://hg.mozilla.org/integration/autoland/rev/e5cb87a13c69
Finish the WorkerHolder cleanup - part 10 - CacheWorkerHolder ported to WorkerRef, r=asuth
https://hg.mozilla.org/integration/autoland/rev/9dc000511baf
Finish the WorkerHolder cleanup - part 11 - WorkerHolder replaced by WorkerRef, r=asuth
You need to log in before you can comment on or make changes to this bug.