Closed Bug 1560021 Opened 1 year ago Closed 1 year ago

As of version 68.0b1, Lightning Task list doensn't remember the last choice of the "Show"-radiobuttons

Categories

(Calendar :: Tasks, defect)

Lightning 68
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: krusea, Assigned: darktrojan)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

  1. Start Thunderbird86.0b1
  2. Open the tasks tab of the Lightning Addon
  3. Choose to show "Current Tasks".
    4, Close and restart Thunderbird
  4. Open the tasks tab of the Lightning Addon

Actual results:

The tasks tab schows "all" tasks, with the "all" radio button marked.

Expected results:

The task tab should only show the tasks that were chosen in the last run, as was the behaviour up to version 67.0bx.
In other words, Thundebird (or Lightning) should remember the choice made.

Verified,

I'll see what kind of regression window this has and figure out the hows.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Untriaged → Add-Ons: General

The Calendar product and Tasks component is probably a better match for this Lightning version 7.0 bug.

I can reproduce this using Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.0 on Ubuntu 18.04.2.

Calendar is a separate product from Thunderbird in Bugzilla. Found under Other from the main Describe Components page.

Component: Add-Ons: General → Tasks
OS: Unspecified → All
Product: Thunderbird → Calendar
Hardware: Unspecified → x86_64
Version: 68 → Lightning 7.0

Tested with Thunderbird 67.0b1 and 67.0b3 with Lightning 6.9 on Ubuntu 18.04.2 LTS Linux and I can't reproduce the bug.

Thanks WaltS48

Tested with Thunderbird 68.0b2 on Windows 8.1 and still can reproduce it (as I expected, but wanted to make sure)

Assignee: nobody → geoff
Status: NEW → ASSIGNED

It looks like with conversion of <radio> to a custom element, we can remove one of the hacks we made to make this work properly.

This undoes bug 1478578 and appears to work.

Attachment #9075285 - Flags: review?(philipp)
Attachment #9075285 - Flags: approval-calendar-beta?(philipp)
Comment on attachment 9075285 [details] [diff] [review]
1560021-remove-radiogroup-hack-1.diff

Review of attachment 9075285 [details] [diff] [review]:
-----------------------------------------------------------------

Assuming you tested bug 1478578 still works, r+
Attachment #9075285 - Flags: review?(philipp)
Attachment #9075285 - Flags: review+
Attachment #9075285 - Flags: approval-calendar-beta?(philipp)
Attachment #9075285 - Flags: approval-calendar-beta+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/56961a825e63
Remove hack to set persisted values on <radiogroup> elements in overlays; r=Fallen

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
OS: All → Unspecified
Hardware: x86_64 → Unspecified
Target Milestone: --- → 7.1

TB 68 beta 4 / Cal 7.0 (well, just aligned that version with TB):
https://hg.mozilla.org/releases/comm-beta/rev/b537951e830a495a1d6390696dd341fbe8408bfd

Target Milestone: 7.1 → 7.0
You need to log in before you can comment on or make changes to this bug.