Closed Bug 1560123 Opened 5 years ago Closed 5 years ago

WebIDL definitions should be listed under "definitions"

Categories

(Webtools :: Searchfox, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1416899

People

(Reporter: Gijs, Unassigned)

Details

STR:

  1. open https://searchfox.org/mozilla-central/search?q=WindowGlobalParent

AR:
2. assume there's no js-exposed thing because there's no idl/webidl showing up under "definitions" near the top.
3. be wrong and then sad.

ER:
show the idl/webidl definition near the top of the results, as a definition.

:mccr8, do you know the state of the idl parsing code?

Flags: needinfo?(continuation)

There's no attempt made to parse WebIDL. We have bug 1416899 on file about indexing WebIDL.

Flags: needinfo?(continuation)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE

My work around is to put .webidl into the file name filter on the right when I'm looking for something. Of course, that only works if you know you are looking for something in WebIDL...

You need to log in before you can comment on or make changes to this bug.