Closed Bug 1560275 Opened 1 year ago Closed 23 days ago

Intermittent /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'vector-effect'. - assert_true: expected true got false

Categories

(Core :: SVG, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: longsonr)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disabled])

Attachments

(4 files, 1 obsolete file)

Filed by: aciure [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=252605463&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/JNucd0nSQ5q_-Tk2MEJm7Q/runs/0/artifacts/public/logs/live_backing.log


[task 2019-06-20T09:23:52.280Z] 09:23:52 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'pathLength'.
[task 2019-06-20T09:23:52.280Z] 09:23:52 INFO - TEST-UNEXPECTED-FAIL | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'vector-effect'. - assert_true: expected true got false
[task 2019-06-20T09:23:52.280Z] 09:23:52 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:133:7
[task 2019-06-20T09:23:52.280Z] 09:23:52 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1594:25
[task 2019-06-20T09:23:52.280Z] 09:23:52 INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-06-20T09:23:52.280Z] 09:23:52 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:131:5
[task 2019-06-20T09:23:52.501Z] 09:23:52 INFO - .
[task 2019-06-20T09:23:52.501Z] 09:23:52 INFO - TEST-OK | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | took 701ms
[task 2019-06-20T09:23:53.169Z] 09:23:53 INFO - Closing logging queue
[task 2019-06-20T09:23:53.169Z] 09:23:53 INFO - queue closed
[task 2019-06-20T09:23:53.187Z] 09:23:53 INFO - Setting up ssl
[task 2019-06-20T09:23:53.208Z] 09:23:53 INFO - certutil |
[task 2019-06-20T09:23:53.249Z] 09:23:53 INFO - certutil |
[task 2019-06-20T09:23:53.265Z] 09:23:53 INFO - certutil |
[task 2019-06-20T09:23:53.265Z] 09:23:53 INFO - Certificate Nickname Trust Attributes
[task 2019-06-20T09:23:53.265Z] 09:23:53 INFO - SSL,S/MIME,JAR/XPI
[task 2019-06-20T09:23:53.265Z] 09:23:53 INFO -
[task 2019-06-20T09:23:53.265Z] 09:23:53 INFO - web-platform-tests CT,,
[task 2019-06-20T09:23:53.265Z] 09:23:53 INFO -
[task 2019-06-20T09:23:55.055Z] 09:23:55 INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2019-06-20T09:23:56.318Z] 09:23:56 INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env9 MOZ_PROCESS_LOG=/tmp/tmpPmdVQ4pidlog --es env8 MOZ_CRASHREPORTER_NO_REPORT=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 STYLO_THREADS=4 --es env2 MOZ_HIDE_RESULTS_TABLE=1 --es env1 R_LOG_VERBOSE=1 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env6 R_LOG_DESTINATION=stderr --es env5 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env4 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --ez use_multiprocess True --es env10 R_LOG_LEVEL=6
[task 2019-06-20T09:23:57.871Z] 09:23:57 INFO - Starting runner

Flags: needinfo?(violet.bugreport)

Yet another Android 7.0 intermittent...

This one is likely caused by the timing issue in the test itself, we should probably use some requestAnimationFrame to ensure style is up-to-date.

I think it's probably only necessary if the intermittent happens on other platforms or too often.

Flags: needinfo?(violet.bugreport)

There are 27 total failures in the last 7 days: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-07-06&endday=2019-07-13&tree=trunk&bug=1560275

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=256301911&repo=mozilla-central&lineNumber=10434

00:32:28 INFO - TEST-START | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg
00:32:28 INFO - Closing window 64424509441
00:32:28 INFO - PID 6444 | [Child 3732, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/c[Parent 11096, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
00:32:28 INFO -
00:32:28 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, no arguments.
00:32:28 INFO - TEST-FAIL | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, non-finite argument. - Value being assigned to SVGPoint.x is not a finite floating-point value.
00:32:28 INFO - adaptPoint@http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:48:7
00:32:28 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:82:51
00:32:28 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1594:25
00:32:28 INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
00:32:28 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:80:5
00:32:28 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, functional test.
00:32:28 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-dasharray'.
00:32:28 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-dashoffset'.
00:32:28 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-miterlimit'.
00:32:28 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-linejoin'.
00:32:28 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-linecap'.
00:32:28 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'pathLength'.
00:32:28 INFO - TEST-UNEXPECTED-FAIL | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'vector-effect'. - assert_true: expected true got false
00:32:28 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:133:7
00:32:28 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1594:25
00:32:28 INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
00:32:28 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:131:5
00:32:28 INFO - .
00:32:28 INFO - TEST-OK | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | took 274ms
00:32:28 INFO - PID 6444 | 1562977948840 Marionette INFO Stopped listening on port 50015
00:32:28 INFO - PID 6444 | JavaScript error: resource:///modules/AsyncTabSwitcher.jsm, line 270: TypeError: browser.frameLoader is null
00:32:28 INFO - PID 6444 | [Parent 11096, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
00:32:28 INFO - PID 6444 | [Parent 11096, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
00:32:28 INFO - PID 6444 | [Parent 11096, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
00:32:28 INFO - PID 6444 | [Child 6676, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
00:32:29 INFO - PID 6444 | [Child 6676, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task[Parent 11096, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
00:32:29 INFO - PID 6444 | [Child 7776, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
00:32:29 INFO - PID 6444 | [Ch[Parent 11096, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
00:32:29 INFO - PID 6444 | [Child 5224, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1562967312/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
00:32:29 INFO - PID 6444 | [Child 5224, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1[GPU 7052, Chrome_ChildThread] WARNING:
00:32:29 INFO - Browser exited with return code 0
00:32:29 INFO - PROCESS LEAKS None
00:32:29 INFO - Closing logging queue
00:32:29 INFO - queue closed
00:32:29 INFO - Setting up ssl
00:32:29 INFO - certutil |
00:32:29 INFO - certutil |
00:32:29 INFO - certutil |
00:32:29 INFO - Certificate Nickname Trust Attributes
00:32:29 INFO - SSL,S/MIME,JAR/XPI
00:32:29 INFO -
00:32:29 INFO - web-platform-tests CT,,
00:32:29 INFO -
00:32:29 INFO - Application command: Z:\task_1562973949\build\application\firefox\firefox.exe -marionette about:blank --wait-for-browser -profile c:\users\task_1562973949\appdata\local\temp\tmpmtm_qb.mozrunner
00:32:29 INFO - Starting runner
00:32:30 INFO - PID 8004 | 1562977950132 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: mozillaAddons
00:32:30 INFO - PID 8004 | 1562977950132 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: telemetry
00:32:30 INFO - PID 8004 | 1562977950132 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: resource://pdf.js/
00:32:30 INFO - PID 8004 | 1562977950132 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: about:reader*
00:32:31 INFO - PID 8004 | 1562977951874 Marionette INFO Listening on port 50015

Sean, could you assign this to someone?

Flags: needinfo?(svoisen)
Whiteboard: [retriggered] → [retriggered][stockwell needswork:owner]

Made a patch to disable this test as there are 173 total failures in the past 30 days and this bug doesn't have an assignee.
:Joel Hi, there are also 4 new failures for Android debug platform and that's why the patch disabled the test for the entire Android platforms.

Flags: needinfo?(jmaher)
Flags: needinfo?(jmaher)
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b07579851b6f
disabled SVGGeometryElement.isPointInStroke-01.svg on android for frequent failures. r=jmaher
Keywords: leave-open
Whiteboard: [retriggered][stockwell needswork:owner] → [stockwell disabled][stockwell needswork:owner]

Cameron, do you want to try to get this test re-enabled?

Flags: needinfo?(svoisen) → needinfo?(cam)

There are 18 failures in the last 7 days on android-em-7-0-x86_64 debug and windows10-64-shippable:
https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-08-30&endday=2019-09-06&tree=trunk&bug=1560275

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=264709024&repo=autoland

[task 2019-09-03T11:22:09.558Z] 11:22:09 INFO - TEST-UNEXPECTED-FAIL | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'vector-effect'. - assert_true: expected true got false
[task 2019-09-03T11:22:09.558Z] 11:22:09 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:133:18
[task 2019-09-03T11:22:09.558Z] 11:22:09 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1611:25
[task 2019-09-03T11:22:09.558Z] 11:22:09 INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-09-03T11:22:09.558Z] 11:22:09 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:131:9
[task 2019-09-03T11:22:09.996Z] 11:22:09 INFO - .
[task 2019-09-03T11:22:09.996Z] 11:22:09 INFO - TEST-OK | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | took 712ms
[task 2019-09-03T11:22:10.648Z] 11:22:10 INFO - Closing logging queue
[task 2019-09-03T11:22:10.648Z] 11:22:10 INFO - queue closed
[task 2019-09-03T11:22:10.655Z] 11:22:10 INFO - Setting up ssl
[task 2019-09-03T11:22:10.676Z] 11:22:10 INFO - certutil |
[task 2019-09-03T11:22:10.696Z] 11:22:10 INFO - certutil |
[task 2019-09-03T11:22:10.712Z] 11:22:10 INFO - certutil |
[task 2019-09-03T11:22:10.712Z] 11:22:10 INFO - Certificate Nickname Trust Attributes
[task 2019-09-03T11:22:10.712Z] 11:22:10 INFO - SSL,S/MIME,JAR/XPI
[task 2019-09-03T11:22:10.712Z] 11:22:10 INFO -
[task 2019-09-03T11:22:10.712Z] 11:22:10 INFO - web-platform-tests CT,,
[task 2019-09-03T11:22:10.712Z] 11:22:10 INFO -
[task 2019-09-03T11:22:13.474Z] 11:22:13 INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2019-09-03T11:22:14.737Z] 11:22:14 INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env9 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env8 R_LOG_DESTINATION=stderr --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 MOZ_HIDE_RESULTS_TABLE=1 --es env2 R_LOG_VERBOSE=1 --es env1 MOZ_WEBRENDER=0 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env6 MOZ_IN_AUTOMATION=1 --es env5 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --es env4 STYLO_THREADS=4 --ez use_multiprocess True --es env12 R_LOG_LEVEL=6 --es env11 MOZ_PROCESS_LOG=/tmp/tmpTqhmULpidlog --es env10 MOZ_CRASHREPORTER_NO_REPORT=1
[task 2019-09-03T11:22:16.134Z] 11:22:16 INFO - Starting runner
[task 2019-09-03T11:22:16.283Z] 11:22:16 INFO - TEST-START | /svg/types/scripted/SVGGraphicsElement.svg
[task 2019-09-03T11:22:16.947Z] 11:22:16 INFO - ...
[task 2019-09-03T11:22:16.947Z] 11:22:16 INFO - TEST-OK | /svg/types/scripted/SVGGraphicsElement.svg | took 663ms

Sean, can you please redirect this to someone who can look into it?

Flags: needinfo?(svoisen)

Hi Geoff, any suggestions here since there is no reply?

Entire history looks like this https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-07-10&endday=2019-11-07&tree=trunk&bug=1560275

There are 13 total failures in the last 7 days on android-em-7-0-x86_64 opt and windows7-32-shippable opt.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=274869914&repo=autoland&lineNumber=5153

[task 2019-11-06T17:59:39.961Z] 17:59:39 INFO - TEST-START | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg
[task 2019-11-06T17:59:40.041Z] 17:59:40 INFO - Closing window 114
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO -
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, no arguments.
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-FAIL | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, non-finite argument. - Value being assigned to SVGPoint.x is not a finite floating-point value.
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - adaptPoint@http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:48:7
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:82:51
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1908:25
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:80:9
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, functional test.
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-dasharray'.
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-dashoffset'.
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-miterlimit'.
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-linejoin'.
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'stroke-linecap'.
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-PASS | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'pathLength'.
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - TEST-UNEXPECTED-FAIL | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | SVGGeometryElement.prototype.isPointInStroke, 'vector-effect'. - assert_true: expected true got false
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:133:18
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1908:25
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-11-06T17:59:40.452Z] 17:59:40 INFO - @http://web-platform.test:8000/svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg:131:9
[task 2019-11-06T17:59:40.891Z] 17:59:40 INFO - .
[task 2019-11-06T17:59:40.891Z] 17:59:40 INFO - TEST-OK | /svg/types/scripted/SVGGeometryElement.isPointInStroke-01.svg | took 932ms
[task 2019-11-06T17:59:41.552Z] 17:59:41 INFO - Closing logging queue

Flags: needinfo?(gbrown)

Let's disable on the additional platforms: all android and windows/opt.

Flags: needinfo?(gbrown)
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/461f2ba0f9b5
disabled SVGGeometryElement.isPointInStroke-01.svg on android and win not debug r=gbrown
Whiteboard: [stockwell disabled][stockwell needswork:owner] → [stockwell disabled]
Assignee: nobody → longsonr
Status: NEW → ASSIGNED
Attachment #9155016 - Attachment description: Bug 1560275 - Flush before trying to read style → Bug 1560275 - Flush before trying to read style in SVGGeometryElement::IsPointInStroke
Pushed by longsonr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/dbc4a4e02865
Flush before trying to read style in SVGGeometryElement::IsPointInStroke r=dholbert,emilio

SVGGeometryElement::IsPointInStroke calls SVGContentUtils::GetCTM and that can call
nsSVGUtils::GetTransformMatrixInUserSpace which needs layout to be up to date

Pushed by longsonr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/715c953ae003
Flush layout in SVGGeometryElement::IsPointInStroke r=dholbert
Attachment #9156823 - Attachment is obsolete: true

Nothing since the latest fix landed.

Status: ASSIGNED → RESOLVED
Closed: 23 days ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Flags: needinfo?(svoisen)
Flags: needinfo?(cam)
You need to log in before you can comment on or make changes to this bug.