Closed Bug 1560336 Opened 1 year ago Closed 1 year ago

Firefox account menu item is misaligned on the right side when signed in

Categories

(Firefox :: Menus, defect, P1)

defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 69
Iteration:
69.3 - Jun 10 - 23
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- verified
firefox69 --- verified

People

(Reporter: dao, Assigned: dao)

References

(Regression)

Details

(Keywords: polish, regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1383535 +++

Can you explain the summary? What is "misaligned", in what way, on what OS?

Flags: needinfo?(dao+bmo)

All OSes, I think, at least I've seen this on Windows and Linux, and the code is shared across platforms. It basically looks like the screenshot in bug 1383535 comment 0.

Flags: needinfo?(dao+bmo)

(In reply to Dão Gottwald [::dao] from comment #3)

It basically looks like the screenshot in bug 1383535 comment 0.

Actually it's slightly worse than that, as not only the hover background is affected; the arrow is too far to the left even without hover.

Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3735712d5323
Stop using the toolbaritem-combined-buttons class for the Firefox account menu item. r=Gijs
Blocks: 1560398
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Fixed on latest Nightly.

Status: RESOLVED → VERIFIED

Comment on attachment 9073025 [details]
Bug 1560336 - Stop using the toolbaritem-combined-buttons class for the Firefox account menu item. r=Gijs

Beta/Release Uplift Approval Request

  • User impact if declined: Firefox account menu item looks off
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): trivial fix
  • String changes made/needed:
Attachment #9073025 - Flags: approval-mozilla-beta?

Comment on attachment 9073025 [details]
Bug 1560336 - Stop using the toolbaritem-combined-buttons class for the Firefox account menu item. r=Gijs

low-risk CSS only fix, beta68+

Attachment #9073025 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I have reproduced this issue using Firefox 69.0a1 (2019.06.20) on Win 10 x64.
I can confirm this issue is fixed, I verified using Firefox 68.0b13 on Win 10 x64, Ubuntu 18.04 x64 and macOS 10.13.6.

Flags: qe-verify+
Iteration: --- → 69.3 - Jun 10 - 23
Points: --- → 1
You need to log in before you can comment on or make changes to this bug.