Closed Bug 1560342 Opened 5 months ago Closed 5 months ago

Factor out Localization out of DOMLocalization

Categories

(Core :: Internationalization, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: zbraniecki, Assigned: zbraniecki)

References

(Regressed 1 open bug)

Details

Attachments

(3 files)

While experimenting with bug 1560038 I realized that we want a C++ Localization class factored out of DOMLocalization class.

This will allow us to move the work on migration from JSM to Rust (or, in fact, any other work on this area) to not touch DOM at all, and be confined to intl/l10n directory.

It'll also allow us to move from XPIDL for mozILocalization to WebIDL and clean up a lot of helper structs that are currently floating between different IDLs. Signatures would also get cleaner.
All in all, goodies.

Assignee: nobody → gandalf
Status: NEW → ASSIGNED
Priority: -- → P3

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e9a6d6d6a41c
Factor Localization out of DOMLocalization. r=smaug
https://hg.mozilla.org/integration/autoland/rev/84ffa3e268c4
Replace generic `object` argument with a specific L10nArgs object for passing l10n arguments. r=smaug
https://hg.mozilla.org/integration/autoland/rev/2de3bf73a764
Add basic tests for Localization. r=stas
Duplicate of this bug: 1388458
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1562642
You need to log in before you can comment on or make changes to this bug.