Open Bug 1560378 Opened 5 months ago Updated Last month

Intermittent docshell/test/navigation/test_bug1364364.html | check history.length after bfcache dropped - got 6, expected 2

Categories

(Core :: DOM: Navigation, defect)

defect
Not set

Tracking

()

REOPENED
Tracking Status
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned, NeedInfo)

Details

(Keywords: intermittent-failure, leave-open, regression, Whiteboard: [retriggered][stockwell unknown])

Attachments

(1 obsolete file)

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=252655167&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/V915LUQuT_izbqDkN-WvHQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-06-20T17:57:25.779Z] 17:57:25 INFO - 159 INFO TEST-PASS | docshell/test/navigation/test_bug1364364.html | check history.length
[task 2019-06-20T17:57:25.779Z] 17:57:25 INFO - Buffered messages finished
[task 2019-06-20T17:57:25.779Z] 17:57:25 INFO - 160 INFO TEST-UNEXPECTED-FAIL | docshell/test/navigation/test_bug1364364.html | check history.length after bfcache dropped - got 6, expected 2
[task 2019-06-20T17:57:25.780Z] 17:57:25 INFO - SimpleTest.is@SimpleTest/SimpleTest.js:320:16
[task 2019-06-20T17:57:25.780Z] 17:57:25 INFO - @docshell/test/navigation/test_bug1364364.html:39:7
[task 2019-06-20T17:57:25.780Z] 17:57:25 INFO - 161 INFO TEST-OK | docshell/test/navigation/test_bug1364364.html | took 1970ms

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Whiteboard: [retriggered]

So I think my patch may have tricked timing so that the browser spends less time doing work... But this test seems racy to begin with...

I'm not familiar with the bfcache code at all. Nika or Farre may be able to dig more easily... Assuming android has the same BFCache setup, the only thing that could be going on is that the bfcache is not (yet?) registered as a mutation observer, or something?

Given my patch didn't cause it (only increased the rate likely due to timing issues), I'd prefer not having to dig into it... But if this is a high priority let me know and I can try to reproduce / debug locally.

Flags: needinfo?(emilio)
Flags: needinfo?(nkochar)
No longer regressed by: 1577258
Whiteboard: [retriggered] → [retriggered][increased frequency with 1577258][stockwell needswork:owner]

Probably me :)
I won't have time this week, but hopefully next week.

Flags: needinfo?(nkochar) → needinfo?(bugs)
Keywords: checkin-needed
Whiteboard: [retriggered][increased frequency with 1577258][stockwell needswork:owner] → [retriggered][stockwell needswork:owner]

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e2dfb26c66c
disabled test_bug1364364.html on android r=gbrown CLOSED TREE

Keywords: checkin-needed
Keywords: leave-open
Whiteboard: [retriggered][stockwell needswork:owner] → [retriggered][stockwell needswork:owner][stockwell disabled]

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:apavel, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(apavel)
Attachment #9089647 - Attachment is obsolete: true

(In reply to Release mgmt bot [:sylvestre / :calixte / :marco for bugbug] from comment #18)

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:apavel, could you have a look please?
For more information, please visit auto_nag documentation.

Landed in comment 12.

Flags: needinfo?(apavel)
You need to log in before you can comment on or make changes to this bug.