Closed Bug 1560432 Opened 5 months ago Closed 5 months ago

Build failure with js shells on Windows

Categories

(Core :: JavaScript Engine, defect, P1, blocker)

All
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: gkw, Assigned: jandem)

References

(Regression)

Details

Attachments

(1 file)

Jan removed NSPR from js shells in bug 1556646 and this broke Windows js shells.

In https://searchfox.org/mozilla-central/rev/da14c413ef663eb1ba246799e94a240f81c42488/js/src/vm/Time.cpp#30 - there is an extra include "prinit.h" in a XP_WIN ifdef.

Compilation seems to work again after the removal of this line. Assigning to Jan (we spoke f2f).

autobisectjs shows this is probably related to the following changeset:

The first bad revision is:
changeset: https://hg.mozilla.org/mozilla-central/rev/b314f6c6148e
user: Jan de Mooij
date: Sat Jun 08 09:10:59 2019 +0000
summary: Bug 1556646 part 2 - Rename JS_POSIX_NSPR to JS_WITHOUT_NSPR and remove --enable-posix-nspr-emulation configure flag. r=sfink,glandium

I fixed my Windows environment and this now bisects correctly to bug 1556646.

Fix in bug 1556646, will change the bug number later.

Priority: -- → P1

Gary noticed we can't build without NSPR on Windows due to this unused #include
inside #ifdef XP_WIN. This patch fixes the build.

Status: NEW → ASSIGNED
Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e99692003796
Remove unused NSPR header from vm/Time.cpp. r=sfink
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.