Closed Bug 1560473 Opened 6 months ago Closed 5 months ago

Two separate messages for an extension controlling the home page and New Tab page

Categories

(Firefox :: Preferences, defect, P3)

67 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: mkumar12, Assigned: mstriemer)

Details

Attachments

(2 files)

Attached image ff bug .jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Opened the settings page.

Actual results:

The message about the app "Momentum", controlling my hope page should have been displayed once.

Expected results:

The same message about the app "Momentum", controlling my hope page got displayed twice!

(In reply to mkumar12 from comment #0)

The same message about the app "Momentum", controlling my hope page got displayed twice!

One message is about the home page, the other about the New Tab page.

Component: Untriaged → Preferences
Summary: Duplicated message in Firefox → Two separate messages for an extension controlling the home page and New Tab page

Mark, do you think we should do anything about this? Most extensions that control the home page will likely also control the New Tab page, and vice versa.

Flags: needinfo?(mstriemer)

So, brushing up on the WebExtension APIs, it seems that even though Firefox ships with the same page for both about:home and about:newtab, it's still very possible for WebExtensions to point the homepage at one site, and the newtab at another:

Homepage: https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/manifest.json/chrome_settings_overrides
New tab: https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/manifest.json/chrome_url_overrides

(In reply to (away 7/8-7/12) Jared Wein [:jaws] (please needinfo? me) from comment #2)

Most extensions that control the home page will likely also control the New Tab page, and vice versa.

This seems likely, but I'm not sure what we'd want to do about it - perhaps the suggestion here is to have a single notification if both the Homepage and New Tab page are overridden with the same URI?

I actually think we're doing the right thing by being more explicit about what the WebExtension is influencing - especially if it happens to be a bad actor WebExtension. I'm tempted to WONTFIX this, but let's give mstriemer a few more days to weigh in.

Combining them could make sense, but not all extensions will set both. I use Tabby Cat which sets the new tab but not the homepage.

When these messages were added there was only an option for changing the homepage in preferences, which I think was a text field, but now there are dropdowns for both options. We've discussed allowing users to change these options rather than disabling the fields which seems like a good approach and has UX approval (bug 1548700). There was an initial patch there but it's stalled now. This doesn't really fit into our model of how extension's settings are managed unfortunately.

Since we've got a row for each of these settings now we should probably put the message next to the setting. I'll attach a patch for that.

Flags: needinfo?(mstriemer)

The priority flag is not set for this bug.
:jaws, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jaws)
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d5c70273b5af
Put homepage extension controlled message next to setting r=jaws
Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Assignee: nobody → mstriemer
Flags: needinfo?(jaws)
Priority: -- → P3
QA Whiteboard: [qa-70b-p2]
You need to log in before you can comment on or make changes to this bug.