about:addons preferences page text is blurry

VERIFIED FIXED in Firefox 69

Status

()

defect
P3
normal
VERIFIED FIXED
Last month
11 days ago

People

(Reporter: ke5trel, Assigned: gw)

Tracking

(Blocks 1 bug, Regression, {correctness, regression})

69 Branch
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox67.0.1 unaffected, firefox68 unaffected, firefox69 verified)

Details

()

Attachments

(2 attachments)

STR:

  1. Make sure gfx.webrender.all = true (Ubuntu 19.04).
  2. Install Decentraleyes extension.
  3. Go to about:addons, click on Decentraleyes and open its Preferences tab.

The text in the preferences page is blurry and too bold. Most extensions appear to be affected, Decentraleyes is more noticeable than some others.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=855d557b82a20e1ed87af46bceac3b918534d37e&tochange=431c5142ff3ad102328d90cb29470b20ccd1271e

Regressed by Bug 1558106.

Confirmed bug & regression range on Ubuntu 19.04 / GTX1060.

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(gwatson)
Keywords: correctness
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

(Offtopic/observation: There seems to be another bug: If I detach this about:addons tab to create a new window, the "Preferences" section becomes empty.)

Also confirmed with Win10/GTX1060. I haven't noticed it elsewhere yet.
good: mozregression --repo autoland --launch 855d557b82a20e1ed87af46bceac3b918534d37e --pref gfx.webrender.all:true -a https://addons.mozilla.org/en-US/firefox/addon/decentraleyes/
bad: mozregression --repo autoland --launch 431c5142ff3ad102328d90cb29470b20ccd1271e --pref gfx.webrender.all:true -a https://addons.mozilla.org/en-US/firefox/addon/decentraleyes/

OS: Linux → All
Priority: -- → P3
Hardware: x86_64 → All
Assignee: nobody → gwatson
Flags: needinfo?(gwatson)

I can reproduce the issue. On non-WR, the subpixel AA rendering gets disabled on the preferences tab panel, due to it having a transparent background.

However, WR is not correctly detecting the case of a transparent background, so it keeps subpixel AA enabled, which gives incorrect blend results.

Some pages from Gecko produce a display list for the main content
tile cache that has a transparent background. Detect these cases
and disable subpixel text rendering to ensure correct blending.

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #2)

(Offtopic/observation: There seems to be another bug: If I detach this about:addons tab to create a new window, the "Preferences" section becomes empty.)

Filed as Bug 1560835.

Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7c911a7be80e
Fix subpixel detection for transparent tile caches. r=kvark
Status: NEW → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Checked on Unbuntu 18.04.2 LTS FF Nightly 69.0a1 with Build ID: 20190619214046) from before the fix and reproduce the issue there.
Unfortunately we did not have Ubuntu version 19.04 and only managed to verify the fix in Unbuntu 18.04.2 LTS 64- Bit and on Win - 64 Bit on Nightly Fx Nightly 70.0a1 (20190711230342) and Beta 69.0b3 (20190708182549).
Release version Ff 68 was unaffected.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.