select boxes cannot be cleared by setting options.length =0

RESOLVED FIXED

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: Tim McLaughlin, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
In all JS 1.5 browsers including NS 6.2, setting the select.options.length value
of a select box to zero clears all options and clears the select box.  Mozilla
1.0 deletes the options, but not clear the value currently displayed.
(Reporter)

Comment 1

16 years ago
Created attachment 90387 [details]
Sample of problem and gross workaround

Comment 2

16 years ago
Confirming with Mozilla trunk binary 20020701xx on WinNT.
Browser, not engine ---> DOM Level 0; cc'ing jkeiser -
Assignee: rogerl → jst
Component: JavaScript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 3

16 years ago
Happens on Linux, too. OS: Win XP ---> All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
jkeiser, don't you have a patch for this rattling around?
Assignee: jst → jkeiser
Whiteboard: DUPEME
(Assignee)

Comment 5

16 years ago
I swear I've seen a bug like this before, but it's not in my bugmail.  bug
136885 was somewhat similar, however.
(Assignee)

Comment 6

16 years ago
Has been fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.