Closed Bug 1560524 Opened 4 months ago Closed 2 months ago

Intermittent TEST-UNEXPECTED-PASS | /media-source/mediasource-seek-beyond-duration.html | Test seeking beyond updated media duration. - expected FAIL

Categories

(Core :: Audio/Video: Playback, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1507193

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disabled])

Attachments

(1 file)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=252778249&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/TbNmDqnbTHKFZ39e660Fwg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-06-21T10:49:06.574Z] 10:49:06 INFO - TEST-START | /media-source/mediasource-seek-beyond-duration.html
[task 2019-06-21T10:49:06.575Z] 10:49:06 INFO - Closing window 2147483793
[task 2019-06-21T10:49:07.385Z] 10:49:07 INFO -
[task 2019-06-21T10:49:07.385Z] 10:49:07 INFO - TEST-UNEXPECTED-PASS | /media-source/mediasource-seek-beyond-duration.html | Test seeking beyond updated media duration. - expected FAIL
[task 2019-06-21T10:49:07.385Z] 10:49:07 INFO - TEST-INFO | expected FAIL
[task 2019-06-21T10:49:07.609Z] 10:49:07 INFO - .
[task 2019-06-21T10:49:07.609Z] 10:49:07 INFO - TEST-ERROR | /media-source/mediasource-seek-beyond-duration.html | took 1038ms
[task 2019-06-21T10:49:08.257Z] 10:49:08 INFO - Closing logging queue
[task 2019-06-21T10:49:08.257Z] 10:49:08 INFO - queue closed
[task 2019-06-21T10:49:08.274Z] 10:49:08 INFO - Setting up ssl
[task 2019-06-21T10:49:08.302Z] 10:49:08 INFO - certutil |
[task 2019-06-21T10:49:08.322Z] 10:49:08 INFO - certutil |
[task 2019-06-21T10:49:08.332Z] 10:49:08 INFO - certutil |
[task 2019-06-21T10:49:08.332Z] 10:49:08 INFO - Certificate Nickname Trust Attributes
[task 2019-06-21T10:49:08.332Z] 10:49:08 INFO - SSL,S/MIME,JAR/XPI
[task 2019-06-21T10:49:08.332Z] 10:49:08 INFO -
[task 2019-06-21T10:49:08.332Z] 10:49:08 INFO - web-platform-tests CT,,
[task 2019-06-21T10:49:08.332Z] 10:49:08 INFO -
[task 2019-06-21T10:49:10.076Z] 10:49:10 INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2019-06-21T10:49:11.329Z] 10:49:11 INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env9 MOZ_PROCESS_LOG=/tmp/tmpXEwGxbpidlog --es env8 MOZ_CRASHREPORTER_NO_REPORT=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 STYLO_THREADS=4 --es env2 MOZ_HIDE_RESULTS_TABLE=1 --es env1 R_LOG_VERBOSE=1 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env6 R_LOG_DESTINATION=stderr --es env5 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env4 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --ez use_multiprocess True --es env10 R_LOG_LEVEL=6
[task 2019-06-21T10:49:13.269Z] 10:49:13 INFO - Starting runner
[task 2019-06-21T10:49:14.231Z] 10:49:14 INFO - TEST-START | /media-source/mediasource-seek-during-pending-seek.html
[task 2019-06-21T10:49:14.266Z] 10:49:14 INFO - Setting pref media.mediasource.experimental.enabled (true)

Hello Graham,
Could this failure be caused by the changes in Bug 1558851?

Flags: needinfo?(james)
Regressed by: 1558851

Maybe, but I think someone from the media team needs to investigate to know if it's a test bug or a gecko bug.

Flags: needinfo?(james) → needinfo?(drno)

In the last 7 days there were 51 failures associated with this bug.
Occurs on android-em-7-0-x86_64 on debug build type.

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=254125937&repo=autoland&lineNumber=3565

[task 2019-06-30T02:27:12.102Z] 02:27:12     INFO - TEST-START | /media-source/mediasource-seek-beyond-duration.html
[task 2019-06-30T02:27:12.106Z] 02:27:12     INFO - Closing window 2147483793
[task 2019-06-30T02:27:13.080Z] 02:27:13     INFO - 
[task 2019-06-30T02:27:13.080Z] 02:27:13     INFO - TEST-UNEXPECTED-PASS | /media-source/mediasource-seek-beyond-duration.html | Test seeking beyond updated media duration. - expected FAIL
[task 2019-06-30T02:27:13.080Z] 02:27:13     INFO - TEST-INFO | expected FAIL
[task 2019-06-30T02:27:13.301Z] 02:27:13     INFO - .
[task 2019-06-30T02:27:13.302Z] 02:27:13     INFO - TEST-ERROR | /media-source/mediasource-seek-beyond-duration.html | took 1197ms
[task 2019-06-30T02:27:14.046Z] 02:27:14     INFO - Closing logging queue
[task 2019-06-30T02:27:14.046Z] 02:27:14     INFO - queue closed
[task 2019-06-30T02:27:14.067Z] 02:27:14     INFO - Setting up ssl
[task 2019-06-30T02:27:14.103Z] 02:27:14     INFO - certutil | 
[task 2019-06-30T02:27:14.123Z] 02:27:14     INFO - certutil | 
[task 2019-06-30T02:27:14.138Z] 02:27:14     INFO - certutil | 
[task 2019-06-30T02:27:14.139Z] 02:27:14     INFO - Certificate Nickname                                         Trust Attributes
[task 2019-06-30T02:27:14.139Z] 02:27:14     INFO -                                                              SSL,S/MIME,JAR/XPI
[task 2019-06-30T02:27:14.139Z] 02:27:14     INFO - 
[task 2019-06-30T02:27:14.139Z] 02:27:14     INFO - web-platform-tests                                           CT,, 

drno: any news on this bug?

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/499fb7e4665f
disable mediasource-seek-beyond-duration.html on android debug r=jmaher
Keywords: leave-open
Whiteboard: [stockwell disabled]

This is getting fixed by bug 1507193.

Status: NEW → RESOLVED
Closed: 2 months ago
Flags: needinfo?(drno)
Resolution: --- → DUPLICATE
Duplicate of bug: 1507193
You need to log in before you can comment on or make changes to this bug.