If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Proxy:Net installer files constantly fail CRC check (Symantec iGear 3.5)

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
VERIFIED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Devin Henderson, Assigned: Curt Patrick (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Beginning with the 1.1a release and for all subsequent trunk nightlies, when I
use the net installer the files fail the CRC check and all files have to be
re-downloaded. They then again fail the CRC check and again start to
re-download. After 3 tries (I think) the installer says 'too many unsuccessful
downloads' and exits. I deleted all of the files in my temp directory, including
the ns_temp folder, but to no avail.

Just recently, however, I realized that if I check 'Save downloaded files
locally' this doesn't happen.
Most people don't see that... any more details about your setup you could give?

Saving the files locally shouldn't make a difference, they're only copied over
to the save location later after they've passed the CRC check. Sean, any ideas?
Assignee: dveditz → curt
(Reporter)

Comment 2

15 years ago
Actually, saving the files locally did work but only about twice. Now files fail
CRC when saving locally as well. What exactly do you want to know about my
setup? I don't know what to tell you. This problem is very strange and
apparently not seen very often. I'm running Windows XP Professional, Mozilla
1.1b as default browser, 512MB RAM, 650 MHz PIII, on a Dell Latitude CPxJ
laptop. This info is probably somewhat useless but I don't know what else to
tell you.

Just tried one more time with the latest trunk and files failed CRC check again.

Comment 3

15 years ago
that's weird.  Saving the files locally should definitely not make a difference
because the "saving" happens after the CRC checks have been performed.  It
probably finally downloaded fine for you.
How are you connected to the internet? Whatever protocol you're trying, could
you switch to the other? (there's a button saying something about proxies near
the end, push it and there are radio buttons to switch between ftp and http)
(Reporter)

Comment 5

15 years ago
i had been using the http method. i switched it to ftp and, after several 'you
have lost your internet connection' errors it finally went through and the files
did not fail the CRC check. i'm not sure why the installer thought my connection
had been lost. i suspect the CRC fails can be attributed to a proxy server that
my internet connection is going through. i had us taken off of the proxy server
and will report back as to whether or not this solves the problem.
(Reporter)

Comment 6

15 years ago
...the proxy server i connect through was not supposed to effect file downloads
such as the moz net installer but i suspect that it was in fact causing the CRC
fails. anyway, i will post again within a couple of days with the results.
(Reporter)

Comment 7

15 years ago
yup, it was the proxy server. sorry for the false alarm. i had been told my
proxy would not cause problems like this but i should have known... setting
resolved: fixed i suppose
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 8

15 years ago
worksforme
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush

Comment 9

15 years ago
reporter, can you find out whose proxy server you were using (vendor) and what
version it was? I think we might want to detect this sort of problem.

[reopening, the correct resolution at this time is WorksForMe, not fixed as
there was no fix to mozilla's source code. I'm hoping we can resolve this bug as
fixed at a later time based on the input I've requested.] Note that if you can't
get this information or don't want you may mark this bug as worksforme.
Status: VERIFIED → UNCONFIRMED
Resolution: FIXED → ---
Summary: Net installer files constantly fail CRC check → Net installer files constantly fail CRC check (caused by bad proxy server)
(Reporter)

Comment 10

15 years ago
the proxy was a Symantec iGear 3.5

Updated

15 years ago
Whiteboard: [nr]
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4 RC1)? If so, then please comment again with details. If not, then
please resolve this bug as WORKSFORME. Thanks.
(Reporter)

Comment 12

15 years ago
worksforme with mozilla 1.4 RC1, resolving bug as WORKSFORME. feel free to
reopen this bug if anyone comes across it again in the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Comment 13

15 years ago
verified
Status: RESOLVED → VERIFIED

Updated

14 years ago
Summary: Net installer files constantly fail CRC check (caused by bad proxy server) → Proxy:Net installer files constantly fail CRC check (Symantec iGear 3.5)
Whiteboard: [nr]
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.