Closed Bug 1560564 Opened 2 years ago Closed 2 years ago

tabswitch broken due to non-local network connections

Categories

(Testing :: Talos, defect)

Version 3
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1559749

People

(Reporter: aswan, Unassigned)

Details

This is a try push with a (slightly old) unmodified mozilla-central:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=b3d37f165f3e5dfc4f13e86d2562fb02e2906195&selectedJob=252817896

The tabswitch test is failing due to a non-local network connection:

FATAL ERROR: Non-local network connections are disabled and a connection attempt to 127.0.0.1.woopra-ns.com (173.239.8.164) was made.

From some local testing, it appears that this connection is coming from the mashable.com page in the tp5o set -- removing that page from tp5o.html allows the test to pass locally.

Joel, did the pageload assets change recently? Or did anything else change?

Flags: needinfo?(jmaher)

Huh, if I just scan recent try jobs (https://treeherder.mozilla.org/#/jobs?repo=try&searchStr=tabswitch) this seems to be broken for a bunch of folks, but its not broken on mozilla-inbound or mozilla-central.

I think I figured out the issue, there is an old version of m-c you are using (june 12th vs 21st), I pulled the tip of m-c 30 minutes ago and pushed to try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=17690fc1405096fe4e6b0f9765635f84c98b82cd

I have another push to determine if artifact builds are the problem, but that now seems irrelevant.

I do suspect this was solved with bug 1559749 where we updated the tp5 pageset to remove some external connections- this was 3 days ago.

Flags: needinfo?(jmaher)

Ah, rebasing to a recent m-c did indeed fix this, sorry for the noise!

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1559749
You need to log in before you can comment on or make changes to this bug.