Closed Bug 1560588 Opened 6 months ago Closed 6 months ago

Fix focus handling in open_chrome_window() for WindowManagerMixin

Categories

(Testing :: Marionette, task, P1)

task

Tracking

(firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

Details

Attachments

(1 file)

The code for handling the focus is out of date and needs to be synced to the one we make use of in browser.js.

This will be the cause of various race conditions when opening other chrome windows.

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9737fcd4ec92
[marionette] Fix focus handling in open_chrome_window() for WindowManagerMixin. r=webdriver-reviewers,ato

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.