If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsICookieStorage not implemented

VERIFIED FIXED in M12

Status

()

Core
Plug-ins
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Robert H. Yang, Assigned: edburns)

Tracking

Trunk
SGI
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
The methods nsICookieStorage::GetCookie() and SetCookie() currently return
E_NOTIMPL.  This is obviously problematic when trying to obtain or set browser
cookies.
(Assignee)

Comment 1

18 years ago
I'm looking at this as well.  Let me know if you intend to fix it.

Updated

18 years ago
Assignee: av → edburns

Comment 2

18 years ago
Reassigning. Thanks.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Comment 3

18 years ago
Created attachment 2182 [details] [diff] [review]
Fix for 15606
(Assignee)

Comment 4

18 years ago
I have attached a patch to this bug which comprises the fix for 15606.  I am
about to attach the regression test patch.
(Assignee)

Updated

18 years ago
Depends on: 16679
(Assignee)

Comment 5

18 years ago
Alex, can you please review this patch?

Ed
(Assignee)

Comment 6

18 years ago
Created attachment 2329 [details] [diff] [review]
Revised fix after shaver's comments
(Assignee)

Comment 7

18 years ago
Created attachment 2333 [details] [diff] [review]
Third attempt after Shaver's comments.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
ryang or edburns, would one of you like to verify this bug? (Otherwise, I can
just rubber-stamp it verified.)
(Reporter)

Comment 9

18 years ago
I'll coordinate it with Ed.  However, can someone clarify what subset of the
Netscape cookie spec and RFC 2109 the implementation will support (that is, how
does it differ from the specs) ?  I've looked at bugs 8743 and 9422 and am
pretty much confused ..

Comment 10

18 years ago
Gagan, could you possibly help ryang with his question? Thank you!

Updated

18 years ago
Hardware: PC → SGI

Comment 11

18 years ago
cc'd neeti and judson.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

18 years ago
Yep, this works for me with today's build.  Thanks !
You need to log in before you can comment on or make changes to this bug.