Awesomebar autofill suggestion presented without bookmark star badge or page title for https://firsttimeux.tumblr.com

RESOLVED DUPLICATE of bug 1468057

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1468057
2 months ago
2 months ago

People

(Reporter: yoasif, Unassigned)

Tracking

({nightly-community})

Trunk
Points:
---

Firefox Tracking Flags

(firefox69 affected)

Details

()

Attachments

(2 attachments)

Steps to reproduce:

  1. Start a new profile
  2. Disable search suggestions in address bar results
  3. Navigate to https://firsttimeux.tumblr.com Another page that exhibits the same behavior is https://firefox-storage-test.glitch.me
  4. Bookmark page, don't make any changes to Firefox suggestion.
  5. Close tab
  6. Forget about site
  7. Type fi into address bar

What happens:

autosuggested URL is https://firsttimeux.tumblr.com with no bookmark star badge attached to the suggestion.

Expected result:

autosuggested page should appear with page title and with bookmark star badge alongside. If searching instead for * fi, I get the result formatted in the way I expect.

It is important to see the bookmark star because it is not obvious why the suggestion is appearing; it is not in my history (not a visited link), if I try to remove the suggestion via shift+delete, it will never delete (because it is bookmarked) -- the UI is not acting in a way that is intuitive - if I knew it was a bookmark, I would understand why shift+delete doesn't work.

Has STR: --- → yes

:yoasif, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

While not exactly what I would prefer to see, this used to be better previously.

While it did not autoselect the correct entry, I was at least able to see the bookmark with the badge in previous versions. Regression log:

8:56.26 INFO: No more inbound revisions, bisection finished.
8:56.26 INFO: Last good revision: 96f25e9de9033887a61358410bf8ecea8c71af15
8:56.26 INFO: First bad revision: e9c7d14fc4a9360b2a4ae94636aa8fe65b16ed72
8:56.26 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=96f25e9de9033887a61358410bf8ecea8c71af15&tochange=e9c7d14fc4a9360b2a4ae94636aa8fe65b16ed72

Summary: Odd behavior when typing query in awesomebar after bookmarking https://firsttimeux.tumblr.com → Awesomebar autofill suggestion presented without bookmark star badge or page title for https://firsttimeux.tumblr.com
See Also: → 1560822
Has Regression Range: --- → yes
Keywords: regression
Regressed by: 1493636

I think the deficiency here is that Firefox doesn't show a bookmark star for the first, preselected result, the one that shows you what will happen when you press enter, even if it's an autofilled and bookmarked domain. iirc there's another bug specifically about that but I can't find it. Bug 1493636 did not change that, so I'm going to remove it from the regressed-by field. What bug 1493636 did do is to autofill bookmarked domains more aggressively, making them more likely to hit that problem.

Please see also my comment in bug 1560821.

Has Regression Range: yes → ---
Keywords: regression
Priority: -- → P5
No longer regressed by: 1493636

Please see bug 1468057 and its duplicate. Bug 1468057 comment 1 has some information about de-duping results.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1468057
You need to log in before you can comment on or make changes to this bug.