Closed Bug 1560699 Opened 11 months ago Closed 10 months ago

Consider downloading ftp:// resources rather than rendering them.

Categories

(Core :: Networking: FTP, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: darkspirit, Assigned: darkspirit)

References

(Blocks 1 open bug, )

Details

(4 keywords, Whiteboard: [necko-triaged][adv-main70-])

Attachments

(1 file)

https://github.com/whatwg/fetch/pull/839#issuecomment-446985221

ckerschb commented on 13 Dec 2018
Firefox has been blocking FTP subresource loads within http(s) documents since Firefox 61 for a variety of reasons as a first step of deprecating FTP resource loads in the browser. It makes sense to me that we start treating FTP resources as binary data instead of rendering them as the next step.

See Also: → 1496725

Please correct me if I put to wrong component.

Component: Networking → Document Navigation
Component: Document Navigation → Networking: FTP
Keywords: site-compat

Loose P1 - let's try to fix this in this release.

Priority: -- → P1
Whiteboard: [necko-triaged]

Michal, this is mostly about changing the content type we expose on the ftp channel. You know this code well, do you think you could fix this for this release?

Flags: needinfo?(michal.novotny)
Duplicate of this bug: 1279621
Duplicate of this bug: 1113145

Tested with emulated Fennec and Desktop Nightly on Debian Testing. Please trigger a try build, if possible.

Rendered: ftp://ftp.de.debian.org/
Downloaded:
ftp://ftp.de.debian.org/debian/README
ftp://ftp.de.debian.org/debian/README.mirrors.html
ftp://ftp.ripe.net/ripe/training/role-object.mov (This would be rendered if we didn't prevent MIME sniffing.)
ftp://ftp.ripe.net/ripe/training/RIPENCC-IPv6-Exercise.pdf

Assignee: nobody → jan

Looks good to me. Thanks for the patch!

Keywords: checkin-needed

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/29e52be56fee
Download FTP resources instead of rendering them. r=michal

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

bug 1475261: Connection errors are empty text instead of error pages. Example: ftp://cyberghost.pro:80/pro.php

Therefore an empty file is now offered to download.

See Also: → 1475261
Regressions: 1576171
Whiteboard: [necko-triaged] → [necko-triaged][adv-main70-]
See Also: → 1591673
Regressions: 1610810
You need to log in before you can comment on or make changes to this bug.