Closed Bug 1560700 Opened 2 years ago Closed 2 years ago

Handle arm[67] rust target on FreeBSD

Categories

(Firefox Build System :: General: Unsupported Platforms, defect)

67 Branch
defect
Not set
normal

Tracking

(firefox-esr68 fixed, firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr68 --- fixed
firefox70 --- fixed

People

(Reporter: loader, Assigned: glandium)

Details

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; FreeBSD i386; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

checking for alsa... yes
checking MOZ_ALSA_CFLAGS... -I/usr/local/include -I/usr/local/include/alsa
checking MOZ_ALSA_LIBS... -L/usr/local/lib -lasound
checking for jack... yes
checking MOZ_JACK_CFLAGS... -I/usr/local/include
checking MOZ_JACK_LIBS... -L/usr/local/lib -ljack -pthread
checking for libpulse... yes
checking MOZ_PULSEAUDIO_CFLAGS... -I/usr/local/include -D_REENTRANT
checking MOZ_PULSEAUDIO_LIBS... -L/usr/local/lib -lpulse -lpthread
checking for rustc... /usr/local/bin/rustc
checking for cargo... /usr/local/bin/cargo
checking rustc version... 1.35.0
checking cargo version... 1.35.0
ERROR: Don't know how to translate armv7-unknown-freebsd13.0-gnueabihf for rustc
===> Script "configure" failed unexpectedly.
Please report the problem to gecko@FreeBSD.org [maintainer] and attach the
"/usr/ports/www/firefox/work/.build/config.log" including the output of the
failure of your make command. Also, it might be a good idea to provide an
overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

% rustc --print target-list | grep freebsd
aarch64-unknown-freebsd
armv6-unknown-freebsd
armv7-unknown-freebsd
i686-unknown-freebsd
powerpc64-unknown-freebsd
x86_64-unknown-freebsd

Component: Untriaged → General
Product: Firefox → Firefox Build System

Can you resubmit the patch on Phabricator? See the workflow notes:
https://developer.mozilla.org/docs/Mozilla/Developer_guide/How_to_Submit_a_Patch

Also, attachment 9073367 [details] fails to apply after bug 1521734:

$ patch -i /path/to/patch-build_moz.configure_rust.configure
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- build/moz.configure/rust.configure.orig    2019-06-16 09:00:42 UTC
|+++ build/moz.configure/rust.configure
--------------------------
Patching file build/moz.configure/rust.configure using Plan A...
Hunk #1 failed at 123.
Hunk #2 failed at 184.
2 out of 2 hunks failed--saving rejects to build/moz.configure/rust.configure.rej
done
Flags: needinfo?(loader)

Martin, does NetBSD need a similar conditional? If so can you suggest a fix or file a separate bug?

Flags: needinfo?(martin)

There's a similar issue on arm linux, and I'd rather address it all in one go.

Assignee: nobody → mh+mozilla
Component: General → General: Unsupported Platforms
Flags: needinfo?(martin)
Flags: needinfo?(loader)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9073367 - Attachment is obsolete: true
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/8a68c8e08c02
Change how the rust target is derived from the build system target. r=froydnj
https://hg.mozilla.org/integration/autoland/rev/36d42617dfd2
Remove now unused allow_unknown argument to split_triplet. r=chmanchester
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Comment on attachment 9084520 [details]
Bug 1560700 - Change how the rust target is derived from the build system target.

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Build issues with more modern rust compiler. Dependency for bug 1587913 and bug 1595218.
  • User impact if declined:
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only a configure check. This brings rust.configure close to being on par with what we have in central (and I'm going to a? some more that will get us even closer)
  • String or UUID changes made by this patch:
Attachment #9084520 - Flags: approval-mozilla-esr68?

Comment on attachment 9084520 [details]
Bug 1560700 - Change how the rust target is derived from the build system target.

approved for 68.9esr

Attachment #9084520 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
You need to log in before you can comment on or make changes to this bug.